Forums/Community/Community questions & answers

Answered

End users getting: Invalid verification token

Billy Catherall
asked this on April 15, 2010 06:07

When an end user follows the link sent in the email for a new ticket they are getting the following error.

"Invalid verification token"

 

This is only happening for end users, emails for agents are working correctly.

 

Comments

User photo
Kris Beveridge
Zendesk
Check Answer

Hi Billy,

This error might crop up if your end users are responding to an old verification email.

For example if an end user has had a new password request but has selected an older verification email, the 'Invalid verification token' will appear.

Another example could be:

An end users ticket is in the suspended tickets folder due to sign up for submitting a ticket requirements. The ticket then gets recovered by your agent but the end user has yet to select the verification link within the email. In this scenario the token will be deemed invalid when the end user selects the verification link.

Best regards,

Kris

April 19, 2010 02:48
User photo
Ron Teitelbaum

I saw this error too.  I added a user and then manually validated them.  I had no idea they would receive this error.  It would be better to not show this error at all if the user was manually validated but if you have to show an error invalid token makes no sense for an end user.  A message like: "User was validated - Thank you" would be better.

Ron Teitelbaum

November 19, 2010 10:35
User photo
Ryna Anderson
thoughtworks

Hi Kris:

When your say "old verification email" what is the expiration time?  We have had a couple of users get error "No such token: "qhsof1azjucrjzp."  These were validated users.  Is there a expiration on users responding to "rate service" emails?

September 20, 2011 13:47
User photo
Jakub Glodek
Zendesk

@Ryna,

For email tokens on welcome messages, those tokens expire if...

* Two weeks has passed 
* After the token is used 
* A password is created for the user by the agent 
* The user is verified by the agent 
* If the help desk is set so users must register, and a resulting suspended by an unregistered user is manually recovered 
* The user is deleted by the agent

September 23, 2011 16:27
User photo
Andrew Bone

Ok so how is this fixed? I do not see a link to revalidate an end user?

We are using the remote authentication and have a link through form our company web site to the Support site. The end user can log into teh company web site OK , but gets a URL that includes invalid+token+for+remite+authentication .. when they click through to the Support site then a prompt to re enter login details.

June 29, 2012 04:31