Forums/Product news and updates/Release notes

Manage tickets from your inbox, Voice in Italy & Spain

Jake Holman
posted this on May 03, 2012 11:57

New Stuff

  • You can now easily control your tickets without ever leaving your inbox, with our newly improved "Mail API". This allows you to use simple commands at the top of the email body to set tags, status, assignee and more. Checkout the documentation.
  • Zendesk Voice is now available in both Spain & Italy! This means phone numbers specific to these countries can now be provisioned.
  • Along with our new API v2 announcement last week, we've also open sourced a Ruby based API Client especially for v2 - you can check it out at https://github.com/zendesk/zendesk_api_client_rb

Fixed Stuff

  • In some rare cases, forum subscription emails were not being sent correctly when a forum received an update. This should now be resolved.
  • When sharing a ticket with a large amount of comments, Zendesk would occasionally block the comment updates - we throttle updates to the same ticket to avoid spamming. We'll no longer be doing this for the initial sharing of a ticket.
  • When changing password, the length validation was incorrectly indicating that the password could be any length. This was purely a UI bug, and still enforced validation on save. The UI issue is now resolved.
 

Comments

User photo
Will Dobbins

When using the mail API if the e-mail has no body text the message is suspended.  It is common for my IT team to send in tickets with nothing in the body, simply a subject that is detailed enough.

May 03, 2012 12:33
User photo
Arnaud de Theux
Zendesk

Not related :) : the new email notification design looks cool, I hope it gets deployed to customers soon!

May 04, 2012 01:27
User photo
Kevin Hill
Crain

Will the old way of using {{ commands }} in the subject line still be supported?

For example:

New ticket {{assignee:John public:false}}

May 04, 2012 07:47
User photo
Richard Bysouth
AJB Systems

Related to the forum subscriptions changes in this release - seems we've either lost lots of forum subscribers (most of them now say "1 subscriber" whereas there were plenty before!) or there's a new bug.

Also, you used to be able to click "n subscribers" to see who was subscribed to a forum or topic. That's gone :(

May 04, 2012 08:38
User photo
Jake Holman
Product Manager

@Richard: That's pretty odd - I'll have someone look into this right away.

May 04, 2012 09:22
User photo
Bryce Pate

Will there be support to set any custom fields we have created for tickets?

May 04, 2012 09:40
User photo
Jake Holman
Product Manager

@Kevin: Yes, the existing subject line stuff will still work. I'd recommend moving away from it, as we'll keep checking on the usage and will drop it once the usage is low enough. 

@Bryce: No plans at the moment I'm afraid.

@Arnaud: We're just experimenting with a new design for now. Once we think it's ready and we've ironed out the per-email client issues we'll start rolling this out for everyone to use. 

@Will: Ah, yes. I'm planning on making some changes to suspended tickets soon, which may well see emails with no content no longer being suspended. For now, I'd recommend putting something in the body, even if it's one character.

@Richard: I've taken a look into your account. I'm able to see the list of people subscribed to a topic, and voted on a topic. However, the ability to see who is subscribed to a forum has never actually been there, as far as I can see looking back through the code base.

I'll create a ticket on your behalf to look into the dip in subscribers though.

May 04, 2012 09:51
User photo
Neil Lillemark
electriccloud

Jake:

 

I feel pretty certain that Richard is correct.  The means to click on the “7 subscribers” and see the list of who those 7 accounts, which you confirmed still exists under each topic, used to also be present at the forum level as well.  Can’t say when that disappeared, but I’m pretty sure it was there a few months ago.

Neil

May 04, 2012 10:39
User photo
Richard Bysouth
AJB Systems

@Neil - thanks for (possibly) reconfirming this!

@Jake - I'm sure it was there because I have used this in the past. For example, we've got an Agents-Only forum. I need to ensure that all agents are subscribed to new posts/comments in that forum, so I've subscribed them to updates at the forum level. When a new agent has joined us, I've been able to quickly go through forums checking who is subscribed to each (by clicking that link "...forum with 5 subscribers"). Unless I've dreamt this up?!

Happy to continue this in a ticket...

May 08, 2012 01:59
User photo
Richard Campbell

I can confirm that being able to click on the number of subscribers at forum level was definitely there, and it technically still appears to be!

If you navigate to the forum you're interested in, the URL will be something like:

http://<YOUR_NAME>.zendesk.com/forums/99999999-NAME-OF-FORUM

Change this to: 

http://<YOUR_NAME>.zendesk.com/forums/99999999/subscribers

And you should be able to see it.


We are currently experimenting with using forums for customer notifications and I was testing it out with a view to using it to ensure all the correct people were subscribed. I have verified that I can still see the list of forum subscribers when I do the above in our environment, but it looks like someone has taken the link away when viewing the main forum page.


Hope this helps! :)

May 08, 2012 07:36
User photo
Richard Bysouth
AJB Systems

@Richard C: yes, that's the one! thanks :D

May 08, 2012 08:06
User photo
John Whiting

I can't get the type and priority fields to update.  I submitted the following email:

#type problem

#priority normal

#public false

 

Updated type and priority

 

## Please do not write below this line ##

but the request still shows these fields as empty. Other fields such as group and assignee work ok??

May 10, 2012 01:46
User photo
Carsten Falborg
IKEA

@John To make a comment private via the new mail API, just write:

#note

May 10, 2012 02:12
User photo
John Whiting

Still can't get #type to work. Tried all permutations of #type problem, #type #problem, #problem, #Problem etc.  All to no avail.  Same with #priority.

May 10, 2012 13:06
User photo
Jake Holman
Product Manager

@John: Gonna create a ticket for you, as I'm able to get this working without an issue. Might be something to do with what you're writing or perhaps your account set up.

May 11, 2012 12:09
User photo
Tiffany Eng

It is very important for us to see who has subscribed to our "announcements" forums. We did used to have this feature and it seems to have disappeared in the last few weeks. Thank's to Richard's comment, I'm relieved to see the subscriber list still exists. Please fix this link when you get a chance! 

June 01, 2012 22:34
User photo
Jake Holman
Product Manager

Sorry for the late update on this. Turns out I was completely wrong, so imagine my smiling face to the left being slightly less smiley and a little more embarrassed.

Anyway, you should now see this functionality once again - when you go to a forum, the widget on the right should tell you the number of subscribers, and that number is linked to a page where you can see each individual subscriber.

June 17, 2012 00:33
Topic is closed for comments