issues with wordpress and zendesk integration

17 Kommentare

  • Matt Butler

    It sounds like you may have two issues going on:

     

    1) In your Zendesk settings, you may have a feature enabled that requires everybody to have an account before they can chat with you. This may be why you are being forced to sign in. That's probably not the best setup when you are using the widget on the website. If you go to SETTINGS > Customers, you have the ability to enable "Anybody can submit tickets". I have this enabled and have the widget working on my website (https://www.intenseit.us).

     

    2) Your server time may be off. If you don't host your website yourself, you may have to get your web host in on this one to resolve the time.

    1
  • breaktheskyinc

    Thanks Matt, with your advice I was able to knock one of the two issues out:

     

    -- I had our server techs change the server clock (it was off by 11 mins) and that fixed the "Remote authentication failed: Invalid iat parameter. The supplied iat value is more than 3 minutes off, check your server clock." issue.

     

    However, I'm still having issues in terms of my wp-admin's dashboard returning the following error:

     

    "Whoops! The user specified as the anonymous requests author is not logged in to Zendesk! You can change the user or kindly ask them to log in. "

     

    I've been able to successfully login to my zendesk portal (I couldn't do this before), and the moving back and forth between my wp-admin and my zendesk portal is working now (before it spat the clock errors), but for some reason my wp-admin is shooting out this error message and I wish I knew how to fix it.

     

    To confirm a couple things:

     

    a) in my wp-admin -> zendesk -> settings, I have "anonymous requests" checked. in the anonymous requests by dropdown field, I don't recognize the username assigned to the email at all (like it's not listed in my wp-admin users list, nor is it listed in my zendesk dashboard), but the email is the same between the zendesk dashboard admin and the wp-admin.

     

    b) in my zendesk dashboard -> settings -> customers, I have "anybody can submit tickets" enabled as well.

     

    Any help on what I need to do to make my wp-admin see a synchronization with the zendesk portal would be appreciated (i.e. do i need to make a new user in the zendesk portal and then make sure a user with the exact same username and email exists i wordpress?). Thanks so much for the help so far!

    0
  • breaktheskyinc

    To add further to this:

     

    I even went and logged into http://MYSITE.zendesk.com/access/normal using the account that has the same email address as the account listed in my "anonymous requests by" dropdown in the wp-admin.

     

    In spite of this, the: "Whoops! The user specified as the anonymous requests author is not logged in to Zendesk! You can change the user or kindly ask them to log in. " error is still there.

     

    All I can think of, is that despite both accounts sharing the same email address, zendesk clearly sees them as separate. So how / what must I do to rectify this?

     

    Hope this info helps.

    0
  • Matt Butler

    It sounds like you are using a Zendesk Plugin for wordpress. I'm using the widget and don't have any experience with the plugin.

    There are no plugins that I know of that were authored by Zendesk. What's the plugins name that you are using?

    0
  • breaktheskyinc

    I'm using the: "Zendesk Support for WordPress"plugin available here: https://wordpress.org/plugins/zendesk/

     

    This plugin is the one that the official zendesk website links to here: https://www.zendesk.com/product/features/wordpress  (click the "download the plugin" button near the top right).

    0
  • breaktheskyinc

    Yes, I even double checked that very thread and my zendesk plugin config in the wp-admin to make sure everything was set correctly. My assumption is I would not be able to successfully login to the zendesk portal using the "login" link at the top right of the main page if these settings were incorrect (id get a different error I expect).

    0
  • Jessie Schutz
    Zendesk team member

    Hey, breaktheskyinc!

    Quick question...are you trying to submit a support request using the email address associated with your agent profile? If you are, try submitting a support request using a non-agent email address (if you haven't done so already). 

    Zendesk recognizes when a support request is being sent from an agent email address and treats it differently. This could mean that a trigger doesn't fire or an error message is received, depending on the channel being used.

    Let me know how it goes!

    0
  • Jessie Schutz
    Zendesk team member

    @Matt - Nice work jumping right in to the Community! We really appreciate your input! :D

    0
  • breaktheskyinc

    From what I understand, internally (as in the communication from my wordpress site to the zendesk portal) utilizes an email address that has to be registered under an agent profile whenever a ticket is made by one of our visitors. 

     

    The very error I see in my wp-admin:

    "Whoops! The user specified as the anonymous requests author is not logged in to Zendesk! You can change the user or kindly ask them to log in."

    implies that the exact same user has to be logged into zendesk as what is specified as the "Anonymous Requests By" user in my wordpress zendesk plugin config  (and I can confirm that they both *do* share the same email address). My zendesk profile / setup is set to only have agents sign in to the portal, noone else.

     

    I'm just trying to figure out how to make the two users (zendesk logged in user / wp-admin "anonymous requests by" user) values match so that this error doesn't appear.

     

    Also, in the wp-admin I only have the one user I can choose from in the dropdown for "anonymous requests by", though my wp-admin has a handful of registered users. My assumption is the zendesk plugin will only list users in that dropdown that share the same email address as registered zendesk agents.

     

    Hope this info helps.

    0
  • Jessie Schutz
    Zendesk team member

    Hey there!

    Okay, I consulted with some of my colleagues on this, and it sounds like there's something buggy going on. I'm going to get a ticket opened up on this for you so we can take a closer look. We'll see you there shortly!

    0
  • DennisVogel

    Did this bug get addressed? I suffer from a similar, if not the same, issue. Looks like it's been about 3 months, with no resolution posted? Thanks.

    0
  • Jessie Schutz
    Zendesk team member

    Hi Dennis!

    I reviewed the ticket that was opened up for the previous poster, and it looks like it wasn't a bug. The user was able to resolve the issue by logging out of Zendesk and logging back in again. I'd recommend giving that a try first.

    If that doesn't do the trick, try uninstalling and re-installing the plugin to see if that takes care of it (this was what was recommended by the Support Advocate in the ticket).

    If neither of those things work for you, go ahead and send a ticket over to support@zendesk.com so we can troubleshoot with you one-on-one!

    0
  • Gui-Berlin

    Hello!

    I've been fighting trying to setup a single sign-on between a wordpress site and Zendesk.

    I checked many many times (oh yeah) the setup, read all what I could find online, followed carefully the tutorials but can't manage to make it work.

    I always end up with the following error:


    I tried on purpose to use the wrong token and then the error message is different and says that the token is wrong. The communication between WP and Zendesk is there but now way to sign in...

    I use the last version of the wp plugin (1.6.4).

    For info, I don't have a ssl encryption on my WP, this is a test WP actually before moving on "live" once I managed to setup the SSO on our "real" domaine (with SSL...).

    I would really appreciate some help :-)

    Thanks in advance!

    Guillaume

     

     PS:  I created in WP an account with the same credential I have in Zendesk as agent. In that case the SSO works. If I am logged in WP and click the link created in the Plugins I am then automatically logged in Zendesk BUT am sent to the Backup (normal I am an agent...)

    1
  • Sam Michaels

    Hey Gui,

    Thanks for reaching out to us.

    Historically, Wordpress integration issues, especially SSO ones, are often difficult to troubleshoot without some back-and-forth between you and an agent who can take a look at what is happening on our end. I have created a ticket on your behalf in our Zendesk. You should see an email shortly. Could you please join me in the ticket when you receive the email?

    If that email does not reach you, please reach out to us at support@zendesk.com for further help on this issue.

    Edit: for anyone interested, the issue was that JWT was enabled for admins but not for end-users on the account. We enabled JWT for end-users (Settings > Security > End-users) and this fixed the problem :-)

    0
  • William Michael

    I had trouble with the Zendesk ticket widget in WP Admin not being able to authenticate.  The problem was that on Zendesk, under Channels > API,  Password Access must be enabled.  Hope that helps someone.



    0
  • Jessie Schutz
    Zendesk team member

    Thanks for hopping in and sharing your solution, William!

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.

Powered by Zendesk