Links aren't working in Trigger Response to Emails

Beantwortet

15 Kommentare

  • Dave Dyson

    Hi Davis,

    It should work if you add the protocol to the url, e.g.: <a href="https://www.google.com">text here</a>

    0
  • Davis Barillas

    @... Yes, that is exactly what we tried and it doesn't work, it comes out as plain text that you cannot click.

    0
  • Davis Barillas

    Dave Dyson is there any other feedback on how to troubleshoot this? Is there some setting we need to enable?

    0
  • Dave Dyson
    Hi Davis, thanks for your patience. I think this may require some deeper investigation – can you try contacting our support team? Contacting Zendesk Customer Support
    0
  • Davis Barillas

    Sorry for the delay, I had to enable Rich content from Admin Settings > Tickets > Settings for <a href></a> tags to work! Cheers!

    0
  • Dave Dyson
    Glad you got it working, Davis!
    0
  • Bart

    Hi Everyone, 

    I think this is no longer working. We've been getting clients reaching out stating it no longer links to our helpcenter. 

    We have rich content enabled with the same <a href=“Our Link to our Help Center”>Help Centre</a>

    So it appears to be broken. 

     

    0
  • Dane
    Zendesk Engineering

    Hi Bart,

    It seems that you are using an incorrect format. It should look like this.

    <a href=“https://www.yourcompany.com/”>Help Centre</a>

     

    0
  • Ivan Kiprin

    Hi, it looks like the ticket settings page has changed - we do not see an option to enable rich content anymore and can't get links to work:
    Is there a workaround for this? We have enabled rich content under Channels > Email > Rich content in email

    0
  • Andres

    My links to the ticket are not coming in as links in the notification emails I have it like this: (also don't see the rich text option in admin)

    Ticket - <a href="{{ticket.url}}">{{ticket.url}}</a> 

    Why isn't it making a clickable link?

    0
  • Gab
    Zendesk Customer Care
    Hi Andres, 
     
    You'll have to locate the notification trigger or automation and select Edit. Then modify the action or actions as needed.
     
    The following placeholders insert ticket links in the email body: {{ticket.link}} or {{ticket.id}}
     
    For information on working with placeholders, see Using placeholders.
    0
  • Andres

    Thanks Gab I will give it a shot. 

    0
  • Aran Liu

    Same issue as Ivan Kiprin, can't find the option to enable rich content and the links are all unclickable at the moment.

    0
  • Dane
    Zendesk Engineering
    Hi Aran,

    Please contact our support directly for us to further check this behavior.
    0
  • Aran Liu

    Dane Thanks, contacted and resolved. Also updating how it was resolved:
    Apparently the best way is re-type the whole code again or copy pasting the html into Notepad before pasting it to Zendesk. The reason of the issue (in my instance) is because some strange and weird code was attached to the link when copy pasting, which on the user end (our end) will seem normal.

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.

Powered by Zendesk