Announcing: Sunset Apps Framework v1 Follow

Comments

17 comments

  • Avatar
    Matt Searle

    How do I know if any of the apps I'm using are built on V1?

  • Avatar
    Kiran Madhav

    Hi Matt,

    Find manifest.json file in you app and then find frameworkVersion. It'll tell you in which version the app was built.

    e.g: "frameworkVersion": "2.0" this is for newer version.

  • Avatar
    Alex Aguilar

    Will ZendeskLab apps be updated to v2?

  • Avatar
    Jessie - Community Manager

    Hey Alex! I checked with a colleague on our Developer Support team, and he said that in general the Labs apps will not be updated to V2. 

    It's important to bear in mind that any apps on V1 will still work; they just won't be updated. So if you're currently using a labs app the version change shouldn't impact their function.

  • Avatar
    Alex Aguilar

    @Jessie

    Thanks. I was looking to add existing apps that are on V1, but can no longer do so since Aug 1st I believe.

  • Avatar
    Jessie - Community Manager

    Hey Alex!

    Do you mean you want to add apps you created on V1 to the marketplace? Or you want to add a V1 app to your Zendesk?

    If it's the former, that is correct. New V1 apps won't be accepted. If it's the latter, you can still install and use V1 Labs apps as long as you get them from the Marketplace.

  • Avatar
    Alex Aguilar

    @Jessie

    The latter, but they're off of GitHub and not the market place.

  • Avatar
    Jessie - Community Manager

    Hey Alex! 

    Unfortunately that's going to be a no-go. Apps from GitHub and other non-Marketplace sources need to uploaded to your Zendesk as a private app, and support for that was ended back on August 1.

    What app were you wanting to use? There might be something similar available in the Marketplace.

  • Avatar
    Michal W

    Good morning!

    I want to ask about private apps.

    After March 1st will I be able to upload v1 apps?
    Do I understand currently that apps that are already installed in my Zendesk with v1, will work just fine?

     

     

  • Avatar
    Phil Grove

    Hi Michal,

    From March 1, 2018, you will no longer be able to submit new or update current v1 private apps but your existing v1 apps will continue to work as normal in your account.

  • Avatar
    Dan Ross

    Are there expectations that future Zendesk changes will break v1 functionalities? We have a few V1 private apps, both in house and external vendors and even some great Labs apps (field manager, an excellent tool!). We're working on our apps, but the ones from other vendors or labs apps are pretty important to our workflows. It would be good to know that's no projected changes that will break these right away. 

  • Avatar
    Alex Aguilar

    We are also using the Ticket Field Manager app (should be added in the marketplace) and I have a question regarding the March 1st date. Are we still allowed to edit the app if it's currently installed? (i.e. add new custom field ids)

  • Avatar
    Nicole - Community Manager

    Hey Dan & Alex - 

    Phil is on vacation this week, but I pinged him and he'll follow up when he's back in the office next week. 

  • Avatar
    Phil Grove

    @Dan, going forward we will not be adding any new features or updates to the v1 framework but we will ensure we do not introduce any breaking changes unless they are announced in line with our breaking change policy.

    @Alex, yes, you will still be able to change the configuration settings of an installed v1 app

  • Avatar
    Pierre-Baptiste BÌ©chu (Edited )

    Hello,

    Our V1 app on the marketplace needs an URGENT fix to be deployed, we can't upload a new version (stil V1) on apps.zendesk.com. What is the process to update our app?

    PS : The errors we are getting during the upload is : 
    Error: Missing required key from translations/en.json: name, installation_instructions

    (which is a typical V2 requirement)

    Thanks :)

  • Avatar
    Bryan Flynn

    Hello Pierre-Baptiste -- this is a known issue. An additional validation apparently was added that broke updates to v1 apps. There should be a fix soon. I'll check with developers on its status.

  • Avatar
    Bryan Flynn

    There is a workaround in the meantime... See the App Internationalization reference documentation for that format that the validation is enforcing. If you basically add the required values to the 'app' property, it should pass validation.


    This has successfully worked for others. Please reply back if this workaround still causes issues for you.

Please sign in to leave a comment.

Powered by Zendesk