Why is the caller ID is showing as unknown, blocked, withheld, or private for outbound calls?

Return to top
Have more questions? Submit a request

5 Comments

  • Pete Neal

    We are experiencing an issue whereby our Australian 1300 number for Zendesk talk presents the CLI with an additional leading 0, which prevents customers from calling us back (gives an invalid number response).

    Please see screenshot below:

     

    I contacted support and they advised:

    The behaviour you are seeing with your toll-free number is expected. As mentioned in our article here Inbound calls "toll-free numbers are for inbound domestic voice calls.  Outbound calls are not supported"

    This seems exceptionally poor service, especially given Twilio do support 1300 numbers as an outbound CLI (just with the above mentioned limitations on Optus/Virgin).

    This is clearly a bug in Zendesk's Twilio integration - any chance of getting it fixed?

    0
  • Devan - Community Manager
    Zendesk Community Team

    Hello Pete Neal,

    After looking over this and your previous ticket, I can confirm this isn't a bug but an aspect of Zendesk not supporting these numbers. I would recommend posting in our Talk Product Feedback forums so our developers can consider adding this as an update to their future roadmap. 

    Best regards. 

    0
  • Pete Neal

    Hi Devan - Community Manager, if Zendesk don't want to support local AU 1300 numbers then perhaps they should consider not selling them? Or not offering Zendesk talk in Australia at all?

    If there was an issue impacting replies to emails from a ".com.au" domain that prevented your Australian customers from using Zendesk support would you consider that acceptable and point me to your developers?

     

    0
  • Ryo Ogochi

    Carl McDowell Pete Neal my team is having some serious issues with zendesk Sell's call thats impacting our business.  Most of my team uses the bridge function to call on their mobile phone via zendesk. 

    Issue: 

    1. The caller ID is not displayed on the customer side. It was showing before but not now.  We have UK, Netherlands, Japan, and US, Canadian zendesk phone numbers. 

    2. Even worse, the personal mobile phone numbers of our sales team are being displayed on the customer side.  We've had customers call our sales team's personal phone numbers which is a real problem.

    We've been taking to your support but not getting ANY response.  Its terrible and causing us a lot of money since customers dont want to answer no caller ID calls. 

     

     

    0
  • Katie Dougherty
    Zendesk Community Team

    Hi Ryo Ogochi,

    Thanks for reaching out!

    I see you already have an open ticket with the Zendesk Customer Support Team. I will be sure to reach out to that team to see if we can get someone to further investigate your account. I would also suggest you reply back to the ticket and give our team a call! 

    In the meantime, it sounds like you might be experiencing an issue: 

    1. With your Sell masking number. A Sell user can select a Sell Voice number but then have our team mask that number so that a different one appears on the caller ID when placing outgoing calls. Our team can check to make sure the masking number is configured correctly and place test calls from your account. 
    2. Please make sure you are placing calls with your Sell Voice number and not using the Transfer Number. When the masking number is activated, your number is masked whenever you call using the call via browser option from your Sell Voice account. The call via transfer number option is unaffected.

    If you have any more questions or feedback on Sell specifically, please feel free to review Sell articles and post on Sell Community Topics

    -1

Please sign in to leave a comment.

Powered by Zendesk