SUMMARY
TIMELINE
15:23 UTC | 07:23 PT
We’re happy to report the issues where some customers may experience problems with sending and receiving emails using the Office 365 integration in Zendesk Sell have now been resolved. Thank you for your patience
15:13 UTC | 07:13 PT
We are currently aware of an issue where some customers may experience problems with sending and receiving emails using the Office 365 integration in Zendesk Sell. We are working to find a solution and will keep you updated as we find out more.
Root Cause Analysis
This incident was caused by a problem issuing new Oauth2 keys for the integration during a standard key rotation. The keys were not taken from the expected library, causing invalid keys to be issued.
Resolution
To fix this issue, Our engineers examined the issued keys and reissued them once they verified the new keys are valid. Once these were in place, system performance returned to normal.
Remediation Items
- We will create a deep documentation of the key rotation procedure for the integration [IN PROGRESS]
- Remove any old keys from our libraries. [IN PROGRESS]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.