Salesforce: Installing the legacy Zendesk for Salesforce integration in Salesforce

Have more questions? Submit a request

47 Comments

  • Kristoffer Rosseth Nebb
    Comment actions Permalink

    Hi,

    I'm trying to relink a site towards Zendesk, but unfortunately this fails. When clicking "Link domain" I get this message: "Remote Site Settings successfully configured. Please click on "Link Domain" again."

    What am I doing wrong (Yes, I've tried to uninstall the package as well)?

    1
  • Benjamin Towne
    Comment actions Permalink

    Hey Kristoffer!

    I see you've submitted a separate ticket with us that I have picked up and sent a reply to.

    Talk to you in that ticket. :)

    0
  • Paul Lee
    Comment actions Permalink

    I have the same problem as Kristoffer.  I tried first w/o configuring remote settings, but after receiving this error, configured remote site settings separately, per the instructions in this article.  However, I still get the same notification and the domain does not link.

    0
  • Benjamin Towne
    Comment actions Permalink

    Hey Paul!

    Thanks for reaching out!

    I see you've also reached out via a Support Ticket.

    I'll reach out to you shortly in that ticket. :)

    0
  • Anwar Husain
    Comment actions Permalink

    Hi there,

    I am new to ZD/Salesforce integration, I have downloaded and installed in our sandbox but I have the following questions:

    When connecting from the sandbox using our company domain, will it cause any issues when we actually connect our production salesforce instance?

    When going through the install steps, you have that message that Zendesk will be able to Read/Write user data, just concerned about what the "Write" option means.

    Any clarification would be greatly appreciated.

     

    Anwar Husain

    0
  • Wilfred Kaw
    Comment actions Permalink

    Hi Anwar,

    Connecting your live Zendesk production instance with your Salesforce sandbox has the potential to affect your live user data in Zendesk. I would highly recommend connecting a Zendesk Sandbox instance to your Salesforce sandbox prolong as you're on an Enterprise plan as the Sandbox instance is available on this plan only. For your reference: https://support.zendesk.com/hc/en-us/articles/203661826-Testing-changes-in-your-sandbox-Enterprise-

    0
  • avs
    Comment actions Permalink

    Hi, 

    I am having the same issue as Kristoffer and Paul had. When I click "Link Domain" button I just get the message "Remote Site Settings successfully configured. Please click on "Link Domain" again." and nothing happens. Can you please help?

    0
  • Laura Hippert
    Comment actions Permalink

    Hi AVS - 

    This is often an issue of an incorrect Salesforce_API Remote Site, and can be resolved just by updating this information in your Remote Site Setting. The following article outlines how this can be done:

    Salesforce: Unable to run Bulk Sync due to ERROR: Remote Site Settings Successfully Configured

    Let me know if you have questions!

    0
  • Adan Fletes
    Comment actions Permalink

    Has anyone run into an issue when doing a mass contact merge in SFDC the Zendesk Contract trigger throws a too many soql queries error?

    0
  • Lawrence Sanders
    Comment actions Permalink

    Hello,

    Firstly, I apologize if this has already been answered.

    I have recently taken over as sysadmin, and am attempting to configure the integration. However, I have found that in order for me to do so, I must make a decision to delete Apex Visualforce code. This must happen in order for the latest version of the SFDC integration to install. 

    Regarding the earlier integration, it had been installed and configured and then abandoned. I do not believe that there is anything remaining that would be broken if deleted. However, I would appreciate it if someone with more expert knowledge could confirm.

     

    Thanks,

    Lawrence

     

     

    0
  • Anika Rani
    Comment actions Permalink

    Hi Lawrence,

    Typically you don't need to delete any code when upgrading to another version. However, this might be due to customisations made on your end. So perhaps you have some visualforce pages that reference fields in the old package which have been removed in the new package you are upgrading to. 

    Sounds like you haven't use the integration in a while though and might have a very old version installed, so hopefully the impact is minimal. 

    0
  • Lionel Kamdem
    Comment actions Permalink

    Hi

    I am unable to download/see the latest version of the Zendesk App for the SANDBOX. 

    https://support.zendesk.com/hc/en-us/articles/203657936

    I have gone to the above link, and I do not see the latest Sandbox version of the app.

    0
  • Anika Rani
    Comment actions Permalink

    Hi Lionel,

    This is now the legacy edition of our Salesforce Integration and is no longer available. As explained in the note at the top of the page, we will be replacing the current integration with our new one which is in an early access program. I would encourage you to sign up for the EAP to test on sandbox: https://support.zendesk.com/hc/en-us/community/topics/360001274594-Zendesk-Integration-EAP-Salesforce-Integration-built-by-Zendesk 

    More info about the removal of the legacy integration: https://support.zendesk.com/hc/en-us/articles/360025775274

    0
  • Kristen Sensenig
    Comment actions Permalink

    We're on a very old version of the SF <> ZD integration, and I had planned to upgrade to 5.8.2 this month. (We're not interested in being in your beta test of the new integration.) I'm I really reading this right today that we can't upgrade the old integration AT ALL? We have to stay on the broken old version for a few months now until you've released the new integration for real?

    We weren't given any heads up on that part of this. I've been planning to update to 5.8.2, and I had no idea you'd yank that before the new integration was ready. This is a really rotten customer experience, guys.

    0
  • Anika Rani
    Comment actions Permalink

    Hi Kristen

    I appreciate your concerns around the upcoming changes to the integration. I've addressed them below generally and will follow up with you directly on a ticket. 

    1. We will continue to support the existing/ legacy integration until it is removed. We will work with you to resolve current issues and the upgrade request directly on the ticket. 

    2. The new integration will be launched into General Availability (out of beta), in mid November, before the existing one is removed in January. We've also designed the new integration to be used alongside the legacy one for an easier transition. 

    3. We are sending out regular communication about the removal. You can expect to hear from us again at the end of September, with more detailed information on making the transition and migration steps. I'll share the details of the comms that have been sent on our ticket and make sure you receive these going forward. 

    0
  • Juhi
    Comment actions Permalink

    Hi,

    Can anyone please let me know if I can upgrade zendesk for salesforce package from 5.7 to 5.8 or not?

    As we need to use the functionality of creating contacts/leads directly from zendesk using Apps in salesforce connected org. And this functionality only works for 5.8 or onward packages. 

    Please reply as soon as possible as its very urgent. 

    Thanks.

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Juhi,

    One of our Advocates will reach out to you through a ticket to discuss this further. We may have to take a look at some account-specific information to determine if this is possible.

    You'll receive an email shortly :)

    0

Please sign in to leave a comment.

Powered by Zendesk