Host mapping - Changing the URL of your Help Center

Have more questions? Submit a request

80 Comments

  • Dirk Koehler
    Comment actions Permalink

    For HSTS is it possible (besides controlling the max-age) to control or set `includeSubdomain` directive on the `strict-transport-security` response header?

    0
  • Alexander Popa
    Comment actions Permalink

    Hi Dirk!

    Unfortunately, amending this would not possible from the Support interface.

    0
  • Dirk Koehler
    Comment actions Permalink

    @Alexander, sounds like it possible outside of the support interface then? if so, what's the process to get it enabled for us?

    0
  • Kevin Sanders
    Comment actions Permalink

    Thanks for the guide - followed these steps and was able to set up support.mydomain (with ZD SSL) perfectly.

    Then, I wanted to update host mapping to use the subdomain help.mydomain which I believed would work just fine according to this guide:

    The SSL certificate covers all your host-mapped domains. Zendesk generates a new SSL certificate when you add, update, or delete a host-mapped domain. Zendesk automatically renews the SSL certificate before it expires.

    I was wrong!  Now, I seem to be completely locked out of my dashboard AND Help Center.  I get "403 Forbidden", SSL cert errors, and I can't log in to the default mydomain.zendesk.com dashboard either because of redirection.

    Any ideas of how I can just revert these changes, and go back to mydomain.zendesk.com?

    Thanks!

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Kevin,

    Looks like you have a ticket created with our Customer Advocacy team here. They'll be able to dig into this further and get you access to your Support account again.

    Thanks!

    0
  • Yule
    Comment actions Permalink

    Hi,

    Initially I added a Hostmap url and enabled zendesk provided ssl.

    Now I have to change the the Hostmap url. In Security I dont see an option to change the Zendesk Provided SSL for the new Hostmap url. I have read a couple of articles asking to disable and renable zendesk provided ssl. But there is no option to disable Zendesk provided ssl, once I have enabled it for a hostmap url.

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Yule,

    Looks like you submitted a ticket to us and one of our Advocates is working with you to get this information updated :)

    Our team will continue working with you on this ticket.

    Cheers!

    0
  • bill
    Comment actions Permalink

    I have the same issue as Yule - initially set up our Host Mapping to support.MYDOMAIN.COM with Let's Encrypt certificate from ZenDesk (this worked) and now can't change it to help.MYDOMAIN.COM as the old certificate for support stays around.  I've tried removing Host Mapping completely, and the Security->SSL page then shows no certificate, but when I add Host Mapping to the new help.MYDOMAIN.COM, the old certificate for support.MYDOMAIN.COM shows up instead of offering me the choice of ZenDesk creating a new Let's Encrypt certificate for help.MYDOMAIN.COM

    I have a support ticket in as well but have not heard back yet.

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hi Bill,

    Can you confirm you've set up the new host-mapping name under Admin>Settings>Account? Additionally, if you want to change your domain you will want to disable the SSL Certificate, update the domain, then re-enable.

    If you continue to run into any issues let me know!

    0
  • bill
    Comment actions Permalink

    Brett and the ZenDesk team solved my problem.  We scheduled a time for me to change the Host Mapping  from support.MYDOMAIN.COM to help.MYDOMAIN.COM, then the ZenDesk folks removed and replaced the Let's Encrypt SSL Certificate with one for help.MYDOMAIN.COM.

    Thanks again to the ZenDesk support team!

    0
  • Brett - Community Manager
    Comment actions Permalink

    Happy to help Bill :) 

    0
  • Bonne Wilce
    Comment actions Permalink

    Hi,
    Is it possible to use host mapping if I have an essential support with professional guide?

    0
  • Patrick Bosmans
    Comment actions Permalink

    Hello Bonnie,

    You would need to be on Team plan or above to take advantage of this feature.

    0
  • Bonne Wilce
    Comment actions Permalink

    Thanks Partrick, The price jump from essential to team is quite large. 
    If i take out an annual subscription and start off with essentials is it possible to upgrade to team later and pay the difference for the year remaining ?

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Bonne,

    If you decide to upgrade to Team at a later date and you're set up with annual billing, you'll only need to pay the difference for the remaining year.

    Let me know if you have any other questions!

    0
  • Charles Fox
    Comment actions Permalink

    This article is great unless you have multiple brands. None of the images or suggested steps match what is available/visible when multiple brands are set up. Although there are articles about multiple brands, there are no articles like this one for a major domain change for a customer with multiple brands.

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Charles,

    The required steps to set up host-mapping should be the same if you were to have multiple brands set up. The only difference would be the location where you enter your subdomain which is touched upon in this article: Setting up multiple brands (Enterprise)

    Are there specific steps in this article that aren't clear when looking at a multi-brand account?

    Let me know!

    0
  • Melody Quinn
    Comment actions Permalink

    We are on Support/Guide enterprise plan and are wanting to change the url of our help site to our own company’s url. In the “Host Mapping” setting under Account I have entered the url we want our help site to be (help.mycompany.live). When an anonymous or end user uses that url (help.mycompany.live), it does go to our help center, however the url that is displayed is our Zendesk url (ourcompany.zendesk.com). Is there a step I am missing?

    0
  • Melody Quinn
    Comment actions Permalink

    It looks like we did not have the Zendesk-provisioned SSL enabled! Problem is solved!!!

    0
  • Brett - Community Manager
    Comment actions Permalink

    Thanks for the update Melody :)

    Glad you were able to get this issue resolved!

    0

Please sign in to leave a comment.

Powered by Zendesk