Removal of support for Internet Explorer 8, 9 & 10 Follow

Announced onDevelopment ends 
March 15th, 2016 April 11th, 2016  

Internet Explorer 8, 9 & 10, released by Microsoft in March 2009, March 2011 and September 2012 respectively, will no longer be supported by Zendesk on April 11th 2016.

Our end of support coincides with Microsoft's own policy, as outlined in their Internet Explorer Lifecycle Policy FAQ.

For more information on how Zendesk generally handles the removal of support for external factors, please see "How does Zendesk deprecate support for external technologies (browsers, devices and integrations)?"

What does this mean?

Currently Zendesk support Internet Explorer 8 and 9 on Web Portal and Help Center, and Internet Explorer 9 on the Agent Interfaces.

On and after April 11th 2016, any issues found to occur exclusively in Internet Explorer 8, 9 or 10 across all Zendesk products will not be resolved.

This will include breaking issues, where Zendesk is not functional for end-users, agents or admins using Internet Explorer 8, 9 or 10.

Why is Zendesk removing this?

Internet Explorer 8 was released over 6 years ago, Internet Explorer 9 over 4 years ago, and Internet Explorer 10 over 3 years ago. It is no longer able to deal with the complexities of today's modern web. In particular it struggles with modern JavaScript.

Supporting Internet Explorer 8, 9 & 10 is somewhat expensive. It requires us to create complex workarounds, and hinders our ability to bring you the best experience for both your agents and end-users.

In January 2016, Microsoft removed support for Internet Explorer 8, 9 & 10 on any desktop platforms beyond Windows 7. This will mean any security problems found within Internet Explorer 8, 9 or 10 will not be resolved by Microsoft, also. 

What do I need to do?

You need to upgrade to a modern web browser. We're big fans of Google Chrome and Mozilla Firefox. If you would like to stick with a Microsoft browser, we recommend Internet Explorer 11.

If you have customers who are still using anything below Internet Explorer 11, you may wish to let them know the support system you are using will be unable to support Internet Explorer 8, 9 or 10.

Who should I contact if I need help or have questions? 

Please contact support@zendesk.com with any additional questions. 

Have more questions? Submit a request

Article is closed for comments.

Powered by Zendesk