Images in emails sent from Help Center subscriptions are broken

Return to top
Have more questions? Submit a request

13 Comments

  • Carrie Hayward

    If broken images is the "expected behavior," why is it that images used to appear in our emails generated by the Help Center, before we switched to the new version of ZenDesk?

    -1
  • Jessie Schutz
    Zendesk team member

    Hey Carrie! I see you're getting help with this in a Support ticket as well; feel free to come back and let us know what you find out!

    0
  • Frankie

    We also just discovered this was the case when a number of customers brought this up. I'm also surprised this is expected behavior. I can understand why this happens, but to me it should still be considered a bug and should be fixed. Otherwise we have to choose between two features that we shouldn't have to...

    1
  • Matthew

    We have just come across this same issue and I do not agree that it should be considered expected behaviour. The content is restricted to logged in users and therefore should not be being emailed in the first place. It should send the announcement telling the user that there is something new to view, with a link to view it online, in the restricted help center, not emailing them the content with broken images. Please change.

    3
  • Jeremy Flanagan

    +1

    I tested to see if it was related to image file extensions (jpg v. png) or user segmentation and content restriction, but no consistency. I got images for one out of 10 articles I tested. This was in chrome on sierra. Similar results on iphone for both gmail app and native mail app. 

    It's just a bad user experience, and not surfacing the body of the article kind of defeats the purpose of answer bot no?

    Any ETA on a fix for this? We put a lot of work into changing our Help Center to make use of these features. This is really discouraging.

    0
  • Tyler B

    This is an incredibly frustrating change, and severely limits the capabilities of Zendesk as a full support solution. 

    0
  • 須藤 玲士

    We faced on the issue that your expected behavior. We strongly request that "your expected behavior" will be improved asap. "Your expected behavior" will be caused to decrease the customer 's satisfaction, and damage us. So would you please consider to improve that customer can find the images on e-mail as soon as possible.

    0
  • Ricardo
    Zendesk Community Team

    Hello everyone,

    I just want to let you know that this behavior has changed and now the images will be visible for 10 days counting from the moment the email is sent. After this time has passed, the images will be broken.

    Thank you.

    0
  • Katina Durrent

    I have a customer who is emailing our Help Center and when I reply back via email with an image it appears as broken. These are new tickets not over 10 days old. We do use SSO. Myself as Admin can view the images no problem.

    0
  • Nicole S.
    Zendesk Community Team

    Hi Katrina -

    Are the emails with the broken images notifications of new posts in your Help Center, i.e. the user is subscribed to an article and someone comments and they're receiving a notification with a broken image? Or are you talking about tickets wherein you're including an image in your ticket response and it's showing up as broken for them?

    Is this happening with all customers or just a specific one?

    0
  • Katina Durrent

    It is Katina. This is not for Help Center articles this is when emailing Help Center Support/submitting a ticket. Happening for all users. 

    0
  • Brett Bowser
    Zendesk Community Team

    Hi Katina,

    Where are these images hosted when you attach them to the ticket? Are you copying and pasting to the ticket or uploading the image directly?

    I've seen this occur when the image being sent is hosted behind a login. 

    Let me know!

    0
  • Katina Durrent

    I have tried attaching to the email from local computer, OneDrive and copy/paste.

    0

Please sign in to leave a comment.

Powered by Zendesk