Setting up your LINE or WeChat channel (Social Messaging add-on)

Have more questions? Submit a request

30 Comments

  • Eugene Ooi
    Comment actions Permalink

    I added WeChat then remove the account and tried to add again but keep getting this error. The AppID and AppSecret is correct. 

    0
  • Stephanie Langlois
    Comment actions Permalink

    Hi Eugene Ooi there are a number of small things we'd need to check to see what's causing the error, such as capitalization caused by the WeChat dashboard being translated from Chinese. Can you please open up a ticket and we can troubleshoot there?

    0
  • John Wong
    Comment actions Permalink

    hi there, we've got the same issue, would you please have a look?

    https://support.zendesk.com/hc/en-us/requests/5280475

    0
  • Eugene Ooi
    Comment actions Permalink

    John Wong, found the solution. You need to copy and paste all the codes using the Chinese version of Wechat. Hope that helps. 

    0
  • John Wong
    Comment actions Permalink

    hi Eugene Ooi,

    thx for the comment, sorry I'm not very sure I follow you, you're meaning it's something about the encoding of the code? and suggesting me to copy it on a Chinese Version Wechat, maybe need Chinese Version OS?

    0
  • Eugene Ooi
    Comment actions Permalink

    John Wong when you copy the AppID, AppSecret and AES Key, make sure you are copying from the Chinese version of the WeChat admin account - https://mp.weixin.qq.com/

    Earlier, I was copying the codes from the English version of the WeChat Admin account and kept getting errors. After I changed to the Chinese Version and copy the codes, I could configure WeChat in Zendesk. 

    0
  • John Wong
    Comment actions Permalink

    hi Eugene Ooi, looks like that Alano and Biety is not comming with me lol, thx you all anyway.

    0
  • Niclas Kårlin
    Comment actions Permalink

    Hello. Has someone made a Zendesk mini-app to be used in WeChat?

    This would make also the agents able to work in wechat, and doesn't have to log in to zendesk app or web.

     

    Also read this:

    https://www.washingtonpost.com/technology/2018/08/09/want-better-customer-service-dont-call-text/

    0
  • Devan - Community Manager
    Comment actions Permalink

    Hello Niclas Kårlin,

    From Zendesk, nothing has been made (yet), but I would suggest sharing this post in our Apps and Integrations Q&A Community topic. Other members might have a few suggestions for ways to find an alternative.

    Best regards. 

    0
  • Owlping OWL
    Comment actions Permalink

    After I install the social message and added the WeChat Channel, WeChat seems can work for receive and send the message to WeChat. However the Persistent Menus disappear that I have setting before migrating to Zendesk social message. How to add the menu in the bottom after activate Zendesk social message WeChat Channel?

    1
  • Ethan
    Comment actions Permalink

    Hi Guys

    I'm also getting the error "Could not add account. Check the values and try again." when trying to add wechat account.

    Not sure if this matters because I saw that in sunshine conversation instructions, but i'm trying to create test account using the wechat sandbox.

    The first time I tried, the URL and token were created by the integration panel on zendesk after entering the ID and secret and then the error appeared but the next time right after entering the ID and secret and clicking "Next" I receive the error.

    By the way, i'm also copying the codes while on chinese version of the wechat dashboard and I'm on Suit Prof plan.

    Appreciate any suggestion or solution. 

    Regards

    1
  • Niclas Kårlin
    Comment actions Permalink

    I can't create the link either.

    I have an old URL and token in wechat (ongair), and I am stuck in step 2 of the guide in zendesk. Don't know if it's a catch 22 here or what the reason might be.

    The sandbox connection works, so maybe it's something with the EncodingAESKey? I don't think it's not the "capitalization" since my key starts with lower case, and my appsecret starts with a number.

    I have tried all three settings of "Message encryption and decryption" in wechat basic configuration.

    https://docs.smooch.io/guide/wechat/#integrate-with-wechat-sandbox

    Zendesk, please create a ticket from my comment if you need to get more details or access to our HC.

    0
  • Nicole - Community Manager
    Comment actions Permalink

    Hi all - 

    Sorry to hear you're having trouble with this! First here are a couple of troubleshooting steps to try: 

    1. Make sure there are no extra whitespaces in the AppID, AppSecret, or AESKey

    2. Make sure that there are no capitalization errors in these values

    3. Ethan and Niclas Kårlin, are either of you using translation of the developer page? 

    Please check those and provide that information, and then we can assist further. 

    0
  • Ethan
    Comment actions Permalink

    Hi Nicole - Community Manager

    Thanks for your reply.

    I'm trying to connect a test account. so no AESKey but others are all correct (no white space / no capitalization error)

    In my first attempt my browser automatically translated the page but later i disabled the translation but results were the same.

     

    Best reagrds

    0
  • Niclas Kårlin
    Comment actions Permalink

    I have the same unsuccessful result. 

    No whitespace (why don't you have Trim() btw?) or capitalization errors.

    I turn off/on translation in Chrome, but the values are the same. I don't think this is a valid reason anymore.

    Please advice! Feel free to open a ticket and access Kollmorgen's account.

    0
  • Nicole - Community Manager
    Comment actions Permalink

    Ethan & Niclas - 

    Thanks for letting us know that the troubleshooting steps did not work. At this point, I will likely need to create tickets to resolve this, but am confirming before I do so. Look for a note from me here tomorrow. 

    0
  • Nicole - Community Manager
    Comment actions Permalink

    Hi guys - 

    The engineers let me know they're seeing several people report issues with WeChat and LINE being reported. I'm going to create tickets for each of you to send to that team. Look for a notification about those tickets in your "my activities" portal or email soon. 


    0
  • Chanus Sathornkich
    Comment actions Permalink

    I have the same issue with Line integration. The error keeps telling could not add the account.

    I'm sure that the account id, account secret and token is correct because I can integrate this Line account to another Zendesk instant successfully. I have multiple Line channels within the same Line account, and all channel can be connected except just one channel. 

    Another clue, I can also connect this Line account to Zendesk with Sunshine Conversation because Sunshine Conversation doesn't require any token from Line account (it needs Line account id and account secret).

    0
  • C L
    Comment actions Permalink

    @Nicole I have the same problem for wechat too. "Could not add account. Check the values and try again."

    Is it fixed? whats the status?

    0
  • Niclas Kårlin
    Comment actions Permalink

    On thispage you write

    On the landing page for Offical Accounts, there are four categories of account types to choose from. We recommend selecting a “Service Account” to integrate with Sunshine Conversations.

    My account is "Subscription number", as found in Account details. Is this not compatible?

    Is certification of wechat account required?

    0
  • Brett - Community Manager
    Comment actions Permalink

    @Chanus, C L, and Niclas thank you for taking the time to share this with us! I'm going to create tickets for you as well so our Advocacy team can look into this further.

    You'll receive an email shortly with your ticket number.

    Cheers!

    0
  • Admin Ari
    Comment actions Permalink

    Hi, I have the same issue with Eugene Ooi but for the Line 

    "Could not add account. Check the values and try again."

    How can I fix this problem?

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Admin Ari,

    Thanks for sharing this with us! I'll generate a ticket on your behalf so we can dig into this further for you.

    Cheers!

    0
  • Diego Yu
    Comment actions Permalink

    Hi, Guys.

    i have the same issue as well, I'm speaking Chinese, I can make sure every information i copy-paste to wechat integration in zendesk is correct.

    But the system keeps noting me couldn't add the account, ask me to check value.

    I haven't input AESKey as I'm not IT guy and it shows optional.

    Still no clear answer and wait a long time to deal with this integration.

    Hope I can get some lovely support, otherwise, I might be fired by my boss as I can't even finish this simple work.

    Thank you!

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Diego,

    Thanks for the heads up! I'm going to create a ticket for you so we can troubleshoot this further.

    Cheers!

    0
  • Diego Yu
    Comment actions Permalink

    Hi Brett, still no response after 9 days.

    I used to catch up with the ticket email but no one reply.

    Any my coworkers receive an email that show how to install whatsapp.

    But actually, we need link WeChat and we already pay the extra fee and follow this instruction try few times.

    Our company do the development of the system as well, we understand some integration issue is not easy.

    But just wish to get some response or clear answer.

    We pay the bill (even not much money), we upgrade the plan for connecting wechat, but finally got nothing, even no response from the tickets for more than one week, even i reply the ticket to ask the status, still no response.

    Hope it can be fixed or give us a clear answer, or if you guys need more information can let me know.

    We love Zendesk, but i can't say I'm not disappointed about this case.

    Thank you!

    0
  • Brett - Community Manager
    Comment actions Permalink

    Hey Diego,

    Apologies for the delayed response! It looks like we're dealing with a high volume of tickets currently which explains why you haven't received a response yet. I've bumped the priority of your ticket to see if we can get eyes on it faster.

    Rest assured our Advocacy team will follow-up with you as soon as they can :)

    Cheers!

    0
  • Niclas Kårlin
    Comment actions Permalink

    From my support ticket with ZD on this matter:

    We are still working on getting this sorted. 
    WeChat has made some changes on their side and they expecting companies like us to become a third party mostly for security reasons.
    This is new on their side and we still going through all the processes to be able to work again with WeChat Official business accounts.

    This blog post from WeChat about “security risks on setting URLs” might be interesting for you: 
    https://developers.weixin.qq.com/community/develop/doc/000c40a3fac2c8b5d279f814c51c09

    We understand that you need to have a working integration as soon as possible, so we are doing all our best to get this sorted.
    0
  • Kcwong
    Comment actions Permalink

    Dear Admin,

    I am having the same issue too. my report ID is  #5535192

    0
  • Nicole - Community Manager
    Comment actions Permalink

    Hi KC,

    Yes, this is an ongoing issue that is actively being worked on. You will likely receive updates in your ticket first, but we will update here once we have a resolution.

    0

Please sign in to leave a comment.

Powered by Zendesk