Salesforce integration: Known issues and troubleshooting

Return to top
Have more questions? Submit a request

14 Comments

  • Ari Hietamäki

    My connection work fine and will sync to zendesk if object is updated. How initial bulk sync can be done?

    2
  • Brett Bowser
    Zendesk Community Team

    Hey Ari,

    There's no bulk sync in the new integration, however, you may want to take a look at the following article on How to Sync Many Accounts/Contact/Leads At Once

    I hope this helps!

    0
  • Lena Gainulina

    Hi, I have two questions concerning ticket sync configuration.

    1. How can I check, what Salesforce case fields are mandatory?
    2. What if there are no corresponding Zendesk fields that match them?
    0
  • Dwight Bussman
    Zendesk team member

    HeyO Lena,

    As I understand it, fields can be marked as required in a few different ways within Salesforce, so question 1 should really be directed to your Salesforce System Administrator who'd be more familiar with field-requirements for your specific workflow.

    As for question 2, our article on Setting up Ticket Sync covers this point:
    "You must map all required Salesforce Case fields. If a required field is not mapped, the sync will fail."

    Much as that sounds a bit harsh, this is how field requirements work within the Salesforce API, so please be sure that you've got those required fields covered. If you're having trouble getting cases to sync, our Support team would be happy to help troubleshoot what might be causing this.

    Thanks!

    1
  • Jason Fouchier

    Hey,

         My integration was working fine until yesterday all the fields were mapped and syncing as they should. At some point yesterday the integration "broke", now it says that all the Salesforce fields I was mapped to are no longer accessible, or have been deleted. The confusing part for me is that I am the System Admin  for both Zendesk and Salesforce and there has been no access changes on my production version of Salesforce. Furthermore, when I look for the fields in Salesforce, they are still there exactly how they were before this issue. I did try changing the accessibility of some of the fields without any luck. I then tried disconnecting and reconnecting to Salesforce using the new managed package, but that didn't solve my issue either. Any ideas or paths I should head down would be greatly appreciated.

     

    Thanks,

         Jason Fouchier 

    0
  • Anika Rani
    Zendesk Product Manager

    Jason Fouchier I can confirm that this was a bug which caused as a result of another change we made. We are currently fixing the issue and it should be released in a few hours. I will post an update here when done.

    Sincere apologies for the inconvenience it has caused you and thanks for posting your feedback here.  

    0
  • Anika Rani
    Zendesk Product Manager

    Jason Fouchier bug has been resolved. Please review your field mappings and let us know if theres any problems. 

    0
  • Jason Fouchier

    Hey Anika,

     

         Thanks for the update, I have checked all my mappings and they all look like they are working as intended.

     

     

    Thanks,

         Jason

    0
  • Luke

    Hi, 

    It appears our Salesforce/Zendesk connection stopped today once we made tickets visible in Salesforce. It was working great. Then the connection ended. 

    When I try to reconnect the integration, I get a page that says this only:

    {"errors":[{"status":"400","code":"1301","detail":" : oauth2: cannot fetch token: 400 Bad Request\nResponse: {\"error\":\"invalid_grant\",\"error_description\":\"ip restricted\"}"}]}


    Any feedback or help would be appreciated as we are excited to get this feature working finally like it was today briefly! Thank you

    0
  • Russell Chee
    Zendesk Customer Advocate

    Hey Luke,

    Thanks for reaching out on this post, I hope you are doing well and apologies for the delayed response!


    Could you check that "locked sessions to ip address from which they originated" is unchecked, OAuth policies are configured correctly and ensuring the relevant profiles listed in the Manage Profiles in the connected app here?

    For more information to double check the settings please see our article here.

    Russell

    0
  • Lakshmi Prasath

    The Zendesk tickets are not updated to Account page

     

    0
  • Nicole S.
    Zendesk Community Team

    Hi Lakshmi,

    Is this a support issue that you need assistance with? If so, could you provide some additional detail about what is happening?

    0
  • Lakshmi Prasath

    Nicole, Yes this issue is resolved now. I tried Russel's link steps. 

    0
  • Dwight Bussman
    Zendesk team member

    Glad to hear that this issue has been resolved by re-linking!

    Dwight B. | Customer Advocate

    Zendesk Experience Research Panel

    0

Please sign in to leave a comment.

Powered by Zendesk