Action needed: Reauthorize the connection between Zendesk Support and your Facebook pages

Return to top
Have more questions? Submit a request

13 Comments

  • Joan Roda

    Hi,

     

    Do we need to deactivate and unlink our current accounts after or before following the steps described in the article?

    0
  • Phil Williams
    Community Moderator

    Possibly yes. I got an error when I first tried the instructions above so I deactivated and unlinked the old page first before repeating the steps.

    The second time around I go a slightly different confirmation message and it saved the settings just fine.

    Others may vary but to be safe I removed and readded.

    1
  • Siobhán J.

    I had the same experience as Phil; experienced a weird error the first attempt, unlinked existing pages, tried again, and saw a proper confirmation message.

    0
  • Nicole S.
    Zendesk Community Team

    Thanks for letting us know, Siobhan. Glad to hear you got it working properly! 

    0
  • Kat Kaho

    Hi I'm having the same issue as Phil and Siobhan. However after many attempts its still not working. After clicking Done as per step 6 above I get this message. 

    When I click on the x to exit out it goes to the settings page and gives me this error 

     

    I've tried what both Phil and Siobhan have done above ie deactivate and unlink and still does not work. Any help/support would be much appreciated!

    0
  • Phil Williams
    Community Moderator

    It might be worth getting Zendesk support involved in this one. I'll get one of the community managers to raise a ticket on your behalf :)

    0
  • Nicole S.
    Zendesk Community Team

    Hi Kat - 

    As Phil said, this sounds a little odd. I'm going to create a ticket for you so that one of our support agents can troubleshoot 1:1 - look for an email notification about that shortly!

    0
  • Julia

    Hi Phil & Nicole,

    I was not aware of this reauthorization. I just realized yesterday that all my Facebook messages are not synced with Zendesk.

    I have tried to disconnect and reauthorize just like Phil said, but still, the Facebook messages are not coming in (I did it 3x). I double-checked to my setting and didn't see anything wrong (like what Kat has experienced). Everything is connected perfectly. Could you advise?

    0
  • Kat Kaho

    Hi Julia

    I've had the issue for over a week and finally jumped on live chat. The solution was much more straight forward than I thought. Click on the 'edit' button in your screenshot above to check your settings. Although I'd selected all to posts or comments to create tickets in Zendesk for some reason the settings itself doesn't apply. So you have to click on edit and select and save. Hope that works for you too.

    0
  • Joren

    Hi,

     

    Issue is that our FB page would always require reauthorization, what is causing this?

    0
  • Erika Camille Sundian
    Zendesk Community Team

    Hey Joren,

    Apologies for the troubles your team is encountering with the Facebook Channel integration always asking to reauthorize. From what I can gather this appears to be a change for the Facebook account used for Zendesk integration. This is the admin/publishing account that is making the connection to your Facebook page that needs updating/reauthorizing. 

    We can't control what Facebook is doing, so for some pages not using 2-factor may work, but maybe required for others. In general though, if you have multiple pages link to Zendesk, you will have to update each page individually. There is no master setting for this. Sorry about that. 

    Hope this helps!

    0
  • Melissa

    Hello,

    I have read through the comments to try to troubleshoot myself but I continue to get an error message when trying to get our Facebook page to connect with ZD. Can someone please step in here for some insight? I first get a green check stating setting were successfully updated. When leaving the page and going back into the facebook settings it gives me this error connecting to Facebook.

    (Like what Kat was experiencing!)

    Please HELP! 

    0
  • Erika Camille Sundian
    Zendesk Community Team

    Hello Melissa,

    Sorry to see you've been running into issues here. I can confirm that this issue or error message you are receiving is usually related to a caching issue within your browser. I have seen users with similar issues able to resolve this by clearing their browser's cache and cookies, logging back in and trying to re-authorize again by following steps on this article. If you're not familiar with this process, I would recommend taking a quick look at the article that outlines how to do so: Options to clear cache and cookies

    If you're still getting the same error after clearing cache and cookies then re-authorizing, I'd recommend raising a ticket with our Support folks to take a closer look into this on your behalf.

    0

Please sign in to leave a comment.

Powered by Zendesk