Help Center adds Rich Text Editing to your Submit a Request forms

Return to top
Have more questions? Submit a request

18 Comments

  • Kevin Ford
    Community Moderator

    This is fantastic! Thank you. I'm seeing a bit of odd behavior. I'm using the latest version of Edge. If I use the WYSIWYG editor on the submit a request page while signed in, I can copy/paste and drag/drop as expected. If I use the submit a request page while I'm not signed in, I can only copy/paste; drag and drop doesn't work.

    0
  • Jeremy Bailey

    Thanks for the good news!

    0
  • Zach Proa

    We are still on v1... what exactly to do I need to do to add this functionality? Is there some code changes that I can simply copy/paste? 

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Kevin Ford thank you for letting us know. Looking into it.

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Zach Proa I suggest setting up a sandbox and try to upgrade your theme's version in there first. If you're lucky (not using any of the deprecated helpers) then it can be as simple as just updating the version in the theme's manifest file. Or else, take a look at the Upgrade Guide.

    0
  • Eric Miller

    I am noticing that on the new_request_page.hbs there is no image icon for uploading images in the toolbar (same as your image in the article above). On the request_page.hbs editor there is the image icon. Why the difference?

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Eric Miller and Kevin Ford actually both your questions relate :-) We haven't enabled the image upload feature when you are not signed in. There are a few issues in that regard that we are working on sorting out, so I expect it to become available at a later date. You should see this capability if you log in though.

    0
  • Kevin Ford
    Community Moderator

    Kasper Sørensen good to know. Thank you.

    0
  • Jeremy Bailey

    Hello Kasper Sørensen, you mentioned that "Zendesk is making the change available to the latest version of the Copenhagen theme shortly," but one of our vendors that uses Zendesk and doesn't use a custom theme hasn't seen this update hit them yet (https://helpcenter.memoq.com/hc). Can you give us an approximate timeframe when this update will reach all customers with default themes?

    0
  • Kevin Ford
    Community Moderator

    Jeremy Bailey it's showing for me in Copenhagen 2.5.0.

    0
  • Gergely Garai - memoQ Ltd.

    Jeremy Bailey Jeremy Bailey, we do use a customized version of Copenhagen :) But it is updated now, and you can use Rich Text editing. Let me know if something's amiss.

    Cheers,
    Gergely

    0
  • Amie B

    Hi Team,

    When will Zendesk actually enable the rich text editor on your own ticket forms in the HC? 

    Feel like I'm in the dark ages now when I submit a request to support and I'm not able to format the message... like I can format this post before I submit it. :)

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Hi Amie B,

    That's exactly what this announcement is addressing :-) We have already made the change available. However, the form is also themeable, so if you've customize your theme, you need to update it as per the instructions. We are also updating Copenhagen theme shortly.

    0
  • Rebecca Dai

    When trying to add on the new_request_page.hbs as described in the article as:

    {{request_form wysiwyg=true}}

    I see an error when trying to save the theme:

    request_form doesn't accept any arguments or options.

    We are on v2, not sure what went wrong there. Did anybody run into the same issue?

    0
  • Amie B

    Hey Kasper,

    I think you're missing my point... support.zendesk.com... the ticket form here does not have the new rich text editor on there. This is what I'm asking when you will turn it on so people who are submitting tickets to Zendesk can format their tickets. My screenshot is from the Zendesk HC form. 

    Best,

    Amie

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Hi Rebecca Dai,

    Hmm that's the exact error you would see if you're on a v1 theme. I think that must be the case for you, can you double check.

    0
  • Kasper Sørensen
    Zendesk Product Manager

    Hi Amie B

    Ah I see! Thanks for correcting me :-) Yes our own Help Center theme hasn't been updated just yet, but it's coming soon :-)

    0
  • Rebecca Dai

    Kasper,

    You were right, we were on v1 of the template. But using v2 of the API, hence the confusion. Thanks for clarifying!

    0

Please sign in to leave a comment.

Powered by Zendesk