SUMMARY
On July 7, 2021 from 12:30 UTC to 15:35 UTC , customers using the Zendesk Talk product experienced incoming call failures and degraded call quality for subsets of Netherlands and Denmark phone numbers.
Timeline
15:45 UTC | 08:45 PT
Talk customers using Netherlands and Denmark phone numbers in the +459 range may have experienced degraded call quality and intermittent call failures. We are working with our provider to resolve the issue and are starting to see recovery. We will continue monitoring and provide another update as soon as more information is available.
16:59 UTC | 09:59 PT
We're happy to report that the issue that caused degraded call quality and intermittent call failures for Talk customers using Netherlands phone numbers and Denmark phone numbers in the +459 range is resolved. Thank you.
POST-MORTEM
Root Cause Analysis
The call failure and call quality degradation issue was caused by a connectivity issue between our Talk partner’s voice platform and the voice platform of their upstream provider.
Resolution
To fix this issue, our Talk partner reconfigured their voice platform to use an alternative internet connection to reach the one on their upstream provider's end. This resolved the issue of packet loss and its associated audio quality issues.
Remediation Items
The following items were undertaken by our Talk partner:
- Implemented a more granular monitoring system on the voice platform [Done]
- Configured the alternative internet connection as the primary connection path [Done]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.