SUMMARY
On August 2, 2021 from 11:34 UTC to 15:20 UTC, customers could have seen incorrect view counts on views with more than 30 tickets when refreshing views or reloading the browser. Only the first page of 30 tickets was returned and pagination was not present.
Timeline
14:44 UTC | 07:44 PT
We are currently aware of an issue with incorrect ticket counts displayed in a view (30) when refreshing the browser page. Investigation is undergoing and we will keep you updated as we find out more. Thank you for patience and apologies for the inconvenience.
15:30 UTC | 08:30 PT
We have deployed a fix to resolve the issue that caused incorrect ticket counts in Views. Please let us know if you still experience any issues.
POST-MORTEM
Root Cause Analysis
This incident was caused by an unexpected CDN provider update which exposed a bug in views functionality.
Resolution
To fix this issue, the CDN provider rolled back the update.
Remediation Items
- Add additional anomaly monitoring for views responses.
- Improve view functionality to better handle similar updates in the future.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.