SUMMARY
Between June 29, 2022 from 10:19 UTC to July 14 17:38 UTC, the Zendesk Z Bot Chat Widget was missing from the Zendesk Help Centre page. Customers may therefore have had issues contacting Zendesk Support from the support.zendesk.com URL. However, the in-product chat widget and the widget at zendesk.com remained available as alternative avenues to get in touch with the Zendesk support team.
Timeline
19:02 UTC | 12:02 PT
We are aware of an issue that has caused the Zendesk Z Bot Chat Widget to contact Zendesk Support at support.zendesk.com to disappear, and our team is investigating. In the meantime, the in-product chat widget and the chat widget at zendesk.com remain available to contact the Zendesk support team.
July 12 21:17 UTC | 14:17 PT
The issue causing the Zendesk Z Bot Chat Widget at support.zendesk.com to disappear is now resolved. You can now reach our support team using the widget on support.zendesk.com.
POST-MORTEM
Root Cause Analysis
Viewing the Request Initiator chain, it was noted that network traffic routed through a partner service. It may have been likely that a setting had been added on that service, causing a change in how cookies set by the widget were used in browsers.
Resolution
To resolve this issue, a patch fix was put in, and we confirmed that the Chat Widget was once again available.
Remediation Items
- Adding a monitor to check that the widget is available in the Help Center [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.
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Post-mortem published July 22, 2022.
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