SUMMARY
On July 10, 2024 from 16:39 UTC to July 11, 2024 16:44 UTC, Support customers with Agent Workspace enabled accounts on multiple pods experienced issues with the ticket audit log feature not displaying dropdown ticket field value changes.
Timeline
July 11, 2024 04:12 PM UTC | July 11, 2024 09:12 AM PT
Our engineers are aware of a Support issue causing drop-down custom field updates to not display in the ticket event timeline. They have identified the root cause and are working on a fix. We will provide an update in 30 minutes or when we have new information to share.
July 11, 2024 05:02 PM UTC | July 11, 2024 10:02 AM PT
Our engineers have completed rollout of the fix and we can confirm that the issue is now fully resolved. Please let us know if you continue to experience issues.
POST-MORTEM
Root Cause Analysis
This incident was caused by an unseen bug in the ticket audit log in a deployed version of the software.
Resolution
A new software version was deployed with the fix. After further monitoring, recovery was confirmed.
Remediation Items
- Adding a regression test to cover changes in ticket fields within the audit log. [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, contact Zendesk customer support.
1 comment
Eugene Khoo
Post-mortem published July 24, 2024.
0