SUMMARY
On September 13, 2024, from 15:00 UTC to 17:04 UTC, customers using the Gmail Connector in Support across All Pods, may have experienced disruptions that prevented the import of emails from recipient addresses. During this period, API calls to fetch batches of emails returned status code 302, indicating that Zendesk's network traffic had been temporarily suspended. Once the block was lifted by Google, the importer was able to catch up on importing the delayed emails.
Timeline
September 13, 2024 03:49 PM UTC | September 13, 2024 08:49 AM PT
We are aware of an issue that is causing delays and potentially preventing incoming emails for customers using the Gmail connector. We are working with our vendor to resolve the issue and will provide further updates when we have new information to share.
September 13, 2024 04:45 PM UTC | September 13, 2024 09:45 AM PT
We are seeing improvement in the issue causing delays and blocked emails for customers using the Gmail connector. We will continue to monitor the situation until full recovery.
September 13, 2024 05:24 PM UTC | September 13, 2024 10:24 AM PT
We are happy to report that the issue affecting inbound emails through the Gmail connector has been resolved, and incoming emails are being processed without delays. Thank you for your patience during our investigation.
POST-MORTEM
Root Cause Analysis
This incident was caused by a temporary suspension imposed by Google on the Gmail Connector, which prevented the import of emails for recipient addresses. The lack of a backup connector for these addresses meant that email imports could not resume until the suspension was lifted.
Resolution
To resolve this issue, the team engaged with Google support to address the suspension. Once Google confirmed that the suspension was not intended and lifted it, the Gmail Connector was able to resume importing emails effectively over the following hour.
Remediation Items
- Fix the email forwarding flow for Gmail addresses to ensure a reliable alternative for email imports during disruptions.
- Consider enhancing notification system alerts to account administrators when a Gmail-connected address stops functioning, allowing them to quickly reconfigure to use email forwarding.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, contact Zendesk customer support.
1 comment
Jessica G.
Post-mortem published October 1, 2024.
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