SUMMARY
On November 25, 2024 from 14:00 UTC to 16:00 UTC, Guide customers were unable to publish or update articles.
Timeline
November 25, 2024 03:36 PM UTC | November 25, 2024 07:36 AM PT
Some customers may be encountering issues when attempting to publish or update articles in Zendesk Guide. Our team is currently investigating the cause and working on a solution.
November 25, 2024 04:00 PM UTC | November 25, 2024 08:00 AM PT
The issue affecting some customers' ability to publish or update articles in Zendesk Guide has been resolved. We apologize for any inconvenience this may have caused.
POST-MORTEM
Root Cause Analysis
This incident was caused by an unexpected defect in the service which handles Guide Articles and their publishing during a routine update.
Resolution
To fix this issue, the update was rolled back until the defect could be addressed.
Remediation Items
- Update testing scenarios to include additional checks for article draft status.
- Remove code path which allowed for the defect to exist.
- Increase internal awareness when publishing similar changes to reduce chance for error.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, contact Zendesk customer support.
1 comment
Billy Macken
Postmortem published December 5, 2024.
0