Not being notified of new tickets, except when I test with personal email

Answered

11 Comments

  • Carsten Falborg - Proventic.dk
    Community Moderator

    Hi Joe

    You need to change current user to your user... That way you and only you will get notified...

    0
  • Joe

    Hi Carsten,

    Thanks for the help. It's currently set to "current user", which is me I suppose. I can't see an option for me specifically or do something sensible like put in my email address.

    0
  • Daniel Cooper
    Community Moderator

    Current user would be the user performing the action. I’m this case the requester would be getting the email and not you. If you want it to just go to you, choose yourself as the user. If a group needs the email select notify group instead.

    1
  • Joe

    Thank you, Daniel. That explains the behaviour I saw perfectly. I still can't seem to select myself or a group from the list given. Anything obvious I'm missing? 

    0
  • Daniel Cooper
    Community Moderator

    When I look at the drop down on my email user action, I see (current user), (requester), (assignee), (all non-restricted agents), and then a list of all of our agents (including light agents).  I would assume you’d be on that list unless you aren’t an agent.  Although if you’re editing triggers, I’m not sure what would restrict you from seeing yourself on the list.  

    The only thing I can think of is maybe your role is an Advisor in Zendesk? This would give you access to business roles but not most of the ticket functionality which might be why you’re restrticted.  I’ve never used that role, but it might be a lead into why you aren’t on the list. 

    0
  • Joe

    Thanks again Daniel. This is what I see: 

    I'm an administrator, on an essential account. I can't test if this is different for as an agent as Zendesk needs an admin (as I'm sure you know)

    0
  • Daniel Cooper
    Community Moderator

    Admin should work the same. I’m assuming it’s because of the essential plan (I thought triggers were part of the Team plan or higher, so that might be part of it). 

    You might try creating a group and only including you in it.  Then try the email group action and point it to your group.  I’m not sure if that will work on Essential. 

    0
  • Jennifer Rowe
    Zendesk Documentation Team

    Hi Joe,

    It looks like what you need to do is not possible on Essential. While it's now possible for to modify and create triggers on Essential, that functionality is limited in the conditions and actions you can use in your triggers.

    I checked in a Professional account and all the individual users appeared in the drop-down. In the Essential account, it's limited to the options you showed in your last comment.

    Sorry about that. Maybe someone will have another recommendation about how to accomplish what you're trying to do. But I don't have any ideas.

    0
  • Joseph Mcarthur (Joe)

    Got it. Thanks, everyone. I managed to kind of do what I wanted (stop everyone being bugged about everything) by restricting all agents other than me to only assigned tickets. Hardly ideal, but if it works it works! 

    1
  • Nicole Saunders
    Zendesk Community Team

    Glad to hear you figured out a workaround, Joe. 

    0
  • Nicole Saunders
    Zendesk Community Team

    This post closed for comment by the Zendesk Community Team. If you have a related or new question, please create a new post

     
    0

Post is closed for comments.

Powered by Zendesk