Set a page background image in Help Center

35 Comments

  • IceCommunityManager
    Comment actions Permalink

    I tried setting a background image on our knowledge base but kept having an issue where the bottom of the background image was being cut off when there was very little content in the main body area of the category, section and article pages.

    I spent a ages trying to find a fix for this and eventually I found the only thing that worked was adding min-height: 900px; to the body { style within the CSS (see images for examples)

    Before

    After

    Hopefully this will stop others having to spend hours looking for the answer and experimenting.

    1
  • Jessie Schutz
    Comment actions Permalink

    Thanks for sharing this, Neil!

    0
  • Scott Reed
    Comment actions Permalink

    If anyone can help with this, I greatly appreciate it. Here's what I did, according to the initial instructions. I added code starting with line 16 and ending line 21. What am I doing wrong?

    0
  • IceCommunityManager
    Comment actions Permalink

    You need to add the code to the CSS tab not on each page. This will automatically add the background to all the pages on your site rather than you having to add the code to each page yourself.

    Basically the code tells the site to place this image on each page between the opening < body > tag and closing </ body > tag. As every page has to have opening and closing body tags it's automatically applied to all pages for you.

    Hope it helps

    0
  • Scott Reed
    Comment actions Permalink

    Thanks for that. I should have clarified that I'm trying to add a background image into the top header area, behind the search window. Do you know how I would add that code into the css tab?

    0

Post is closed for comments.

Powered by Zendesk