Embed Videos in Help Center Articles with Two Easy Steps (using video.js)

105 Comments

  • Elizabeth Washington

    @Wes - I know this article is a bit old, but I was trying to implement your suggestion regarding the video icon showing on help articles that contain the word video. I have added the code you indicated in the document head, css and js but I am not seeing anything. Any suggestions on how to troubleshoot this further? Really appreciate your help!

    1
  • Jessie - Community Manager

    Hey Sébastian!

    Thanks for the heads up on this! I'll send it over to our Documentation team so they can take a look. :)

    1
  • Sébastien ROUL

    Ok super, since this article was written browser's security evolved a lot 😀

    0
  • Shanti de Ruyter

    You have an error in your instructions:

    <link is duplicated.

    0
  • Wes Drury

    @Shanti - Thanks for catching the error :-)

    0
  • David

    Where and in what format does the video need to be stored in order to be able to embed it like this?

     

    1
  • Nate Legakis

    Is all this necessary if I just want to embed a vimeo video with an iframe?

    0
  • Jennifer Rowe

    Hi Nate,

    No, you don't need to do this if your video is hosted on Vimeo.

    To add that video to an article, you just need to paste the embed code into the source code of the article.

    Good luck! 

    0
  • Sunee Lewitzky

    Hey @Wes. Thanks for this tutorial! I have a quick question. We only offer our product via our mobile (IOS) app, and so that is where most of our customer base views help articles. We are starting to put videos in the articles and have been hosting them on Youtube, but I am looking for an unbranded solution.

    From what I can remember, HTML videos will not play on IOS unless they are in an iFrame, is that correct? (Because there is no flash player)

    If so, do you have any other suggestions for embedding videos that do not require HTML and will be mobile friendly?

    0
  • Wes Drury

    @Sunee - Sorry I'm not an expert on videos or IOS so I don't know all the rules.  I'm sure there is something out there that will meet your needs if the solution I provided does not work.

    0
  • Akhilesh PV

    Hi @Wes Drury - Thanks for this tutorial. I have follow the instructions that available in this tutorial. I can see the video in editor. But video not display when I open the article in Help Center. When I inspect the elements, the <video> tag not displaied in the article.

    Steps I follow:

    1. Added the VideoJs CSS and JS file in Document Head

    2. Upload the  MP4 video in my server and added the video URL on source tag

    3. Upload the  PNG poster in server and added the URL with poster param

    Could you please help me to solve this issue?

    Thanks

    0
  • Wes Drury

    @Akhilesh PV - Please make sure in your Guide settings that you checked the box for "Display Unsafe Content".  Let me know if that helps at all.

    0
  • Akhilesh PV

    Hi @Wes Drury - Thanks for your support. its working now.

    Thanks...

    0
  • Dolev Zemer

    Hi! :-)

    Am I correct in assuming that we need to be in the Guide Professional plan and above to enable this?

    0
  • Nicole - Community Manager

    Hi Dolev -

    That's correct. You'd have to be able to customize your Guide, which is not available on the Essential plan.

    0

Please sign in to leave a comment.

Powered by Zendesk