How to use Google Apps email address and your own domain with Zendesk

Comments

63 comments

  • Avatar
    Raheel N.

    Thanks for this, we have followed almost all steps above including setting up SPF records but we aren't able to send outgoing mail once a ticket is created. Is there something that we're not catching? All our support emails are created as groups in google apps, we are forwarding mail from the group (support@company.com) to the zendesk sub domain properly as well. Does this have anything to do with it or have we not set something up properly?

  • Avatar
    Vladimir Kochkovski

    Thank you for your comment @Raheel. Let's try to get this sorted out. First, have you tried testing it with an email address outside of your domain? I'm asking this just to make sure that the email address doesn't block the returning message.

    Also, in your Zendesk dashboard check for Suspended tickets. This might give a clue why they are not reaching the destination.

  • Avatar
    Raheel N.

    Hey Vladimir,

    Thanks for your help, we actually figured out that a TRIGGER of all things was disabled in the settings (the trigger for notifying requester once a comment is updated). Sometimes problems are so minor you don't think that they could be causing the issue! All is well now, and your guide is working for us as we have multiple addresses as well as multiple domains.

    This is kind of forcing us to rename our Zendesk a generalized helpdesk like "Support Helpdesk" because we can't have Company A's name as the sender when customers send e-mails to Company B. If we wanted this functionality we'd have to upgrade to the Enterprise plan (way out of our price range).

    One thing I would add is that we also enabled sending additional copy of the email as we have a backup account we send all of our support e-mails to. With the settings for default routing above the email was skipping the account it normally sends to, we added the additional copy option and everything is working as it should!

  • Avatar
    Vladimir Kochkovski

    @Raheel I'm glad you found the solution and thank you for sharing!

  • Avatar
    Adrian Walls

    We have two separate support email address support@domain1.com and support@domain2.com relating to two individual products.  We'd like to deal with these separately in Zendesk but in our Google Apps account domain2.com is an alias of domain1.com.  Therefore:

    • Will this same process work?
    • Do we need to add domain2.com as a standalone domain in Google Apps in order to allow us to separate the routing on the individual domains? 
    • Or do we need to set this up in some other way?

    Thanks in advance.

  • Avatar
    Vladimir Kochkovski

    Hey Adrian,

    The same process will work on Zendesk side, and you need to check if in Google Apps is allowed to create email routing for the second alias (which I think it is).

    One possible solution is for domain1.com to use the procedure above as usual,
    and for domain2.com, try this:

    Test it out first, just to make sure.

    Another option would be to get the Zendesk subscription that allows multiple domains.

    Let me know if it works out for you. If you need any help, feel free to contact me at ask@getvladimir.com

  • Avatar
    Adrian Walls

    Thanks Vladimir.  We have just decided to set-up a new Zendesk account for this as it is a completely separate entity. But this is still useful to know.

  • Avatar
    Vladimir Kochkovski

    That's awesome, Adrian! I'm glad you found a solution and thank you for sharing it!

  • Avatar
    Katja Llach

    Hello, 

    I was able to successfully set up my email so that it forwarded to the zendesk email. However I would like to still access the emails as a backup in case there is an issue with Zendesk. (I actually already had an issue and lost files due to this issue.) How can I set it up so that I have a back-up copy in my email account?

    Thank you!

  • Avatar
    Vladimir Kochkovski

    Hi Katja,

     

    Thank you for watching the tutorial and I'm glad you got it set up successfully. Sorry to hear that you had issues with Zendesk. Please report the problem to the support team and they will make sure it doesn't happen again. They are awesome for that :)

     

    Getting back to your question, there is an easy way to add a back-up email also. On the same screen where you changed the settings in Google Apps, scroll all the way down and select "Add more recipients". (I have included a screen shot  as an attachment to make it more visually clear).

     

    Just add the email address where you would like the emails to be forwarded and you will get an exact copy of the inbound tickets, just in case.

     

     

    If you need any help, please feel free to contact me.

  • Avatar
    Katja Llach

    Thank you! It did not work when I used the original email address I was forwarding (support@mydomain.com), however I created an alias on that account and now it is working. So I have supportbackup@mydomain.com that is now receiving the emails. Thanks for your help and quick response!

  • Avatar
    Vladimir Kochkovski

    Great :) I'm glad you got it working and thank you for sharing your solution.

    If you need any help in the future, please feel free to contact me

  • Avatar
    Dan Lewis

    Might be time to update this article.

    It refers to enabling pass-through email addresses. However a warning banner in our Zendesk says these are being phased out in the next few months.

  • Avatar
    Vladimir Kochkovski

    Thank you, Dan Lewis, for the comment and for the heads-up. I have updated the article :)

  • Avatar
    DJ Jimenez

    Is this no longer available from the Google Apps Marketplace?

  • Avatar
    Vladimir Kochkovski

    Thank you for the comment, DJ Jimenez. Didn't find an app in the Google Apps Marketplace that does this. You will need to do the procedure manually.

     

    Update: Since the Google Apps interface is changed, to get to the Email Routing now you will need to login to admin.google.com and:

    1. Press on the "Apps" icon
    2. Choose "Google Apps"
    3. Press on "Gmail"
    4. Scroll down and press on "Advanced settings"
    5. From the top menu, choose the "Default routing" tab

    The procedure still works.

     

    If you have any additional questions, please feel free to contact me or leave a comment here.

  • Avatar
    Jon Alsup

    Okay, so we did the SPF redirect and added the google emails that we needed in the support desk and only one of the emails we associated with our help desk is working. We need some help! 

     

  • Avatar
    Vladimir Kochkovski

    Hi Jon,

    Thank you for the details. Did you also added the email addresses in Zendesk? (please note that they should all be under the same domain name)

  • Avatar
    Philippe

    Default routing seems to only be available for Google Apps for Work and Google Apps for Education customer (https://support.google.com/a/answer/2368153?hl=en). Any solution for standard Google Apps accounts?

  • Avatar
    Vladimir Kochkovski

    Hi Prollin,

    No, the Email Routing option is not available on the free version of Google Apps (as that version is also discontinued now).

    You will need to get one of the paid versions of Google Apps for Work in order to have access to the advanced features.

  • Avatar
    Philippe

    Thanks for the quick reply Vladimir.

    Discontinued or not I am sure there are still a lot of ppl still using the free Google Apps.

    Anyway, a way around this is to create a group (Admin console -> Groups -> Create Group) with the desired email and add support@company.zendesk.com as a member of that group.

  • Avatar
    Frank Mile (Edited )

    Maybe I'm wrong, but snapping your own domain to google apps is not free itself.

  • Avatar
    Elihu Bogan

    Hey there - I'm getting 'invalid record name' when copying/pasting the following value into the TXT record on Linode:

    v=spf1 include:mail.zendesk.com include:_spf.google.com include:_spf.zdsys.com include:support.zendesk.com include:smtp.zendesk.com ?all

    Am I missing something in the formatting? Thanks

     

  • Avatar
    Vladimir Kochkovski

    Hi Elihu,

    Doesn't seem like you're missing anything. Just double-check that there are no extra spaces of other characters (break space) in between.

    If you're still having issues, might be that the host doesn't allow long TXT records.

  • Avatar
    Support

    Followed your instructions. When I submit a ticket to support@myaddress.com I get alerted in the zendesk dashboard and get an email at my support@ inbox. 

    The person submitting the ticket isn't getting a response that they created a ticket. Also when I reply in the zendesk dashboard the user never gets an email about the ticket.

    Help!

  • Avatar
    Vladimir Kochkovski

    Hi Steve,

    If you receive the email in your dashboard, it seems like the email is working properly.

    Please check if you have your Email Triggers set up correctly and enabled (they are on by default). If not, please contact support and ask for help setting them up.

  • Avatar
    Support

    Thanks Vladimir. I did ask support and they told me I don't have an account that gets supports and to use the forums. 

    My support email is an alias if that makes a difference.

  • Avatar
    Vladimir Kochkovski

    Well that's odd. Please feel free to ask anything here then.

    To get you up and running, here is the link for the triggers:

    https://www.zendesk.com/blog/default-triggers-explained/

  • Avatar
    Support (Edited )

    All my triggers are on. I also testing emailing my support desk with the @mydomain.zendesk email and still doesn't work when replying in the dashboard. Any ideas?

    UPDATE: I was testing with an email I originally signed up with Zendesk with. Make sure to test with a completely separate email address or you won't get the initial triggers. 

  • Avatar
    Vladimir Kochkovski

    If you can, please feel free to contact me directly at ask@getvladimir.com so that we don't flood the comments here :)

Please sign in to leave a comment.

Powered by Zendesk