0

Can't access installed apps.

I have installed Harvest, Freshbooks, and a private app that I was testing.
Just now, whenever I try to access my sidebar apps, it says "there are no apps installed in this account".

Is anyone else having this problem? 

12 comments

  • 0

    Hey Nicu, have you refreshed your browser at all? I know it's not super intuitive (yet, we're working on it!) but you need to refresh the interface whenever you install an app.

  • 0

    I am also having this problem.  I have refreshed my browser.

  • 0

    @Jake, any updates on this yet?

  • 0

    @Finley: You actually have something wrong with an app you uploaded - it's throwing an exception right now, you're able to see this in your console. Feel free to attach your .zip and I'll have a look.

    @Nicu: Likely the same for you I'm afraid.

  • 0

    Hello Jake,

    For me it doesn't throw an exception. I guess the content of the app.js should appear in the *.zendesk.com/api/v2/apps/installed.js file? It stays blank for me.

    I think there is a need (or at least for Finley and me), to have a working example app.
    https://support.zendesk.com/entries/21695767-can-we-get-an-example-app
    A simple 'Hello World' app would do for now, as I just can't get anything to work ;)

    Cheers,

    Sebastiaan

  • 0

    @Sebastiaan: There's a zip download available at  http://developer.zendesk.com/documentation/apps/example.html#download - it's not a hello world example, we opted for a fully working example of an app, which we then deep dive into for the entire documentation at  http://developer.zendesk.com/documentation/apps/getting-started.html - recommend reading the whole thing before trying to upload stuff

  • 0

    Thanks Jake!

    I went through the documentation, but I couldn't get the app to work. Will compare it with the download to see where it went wrong.

  • 0

    You're welcome to post your .zip file here, if there's no super secrets in there! We're happy to take a look at people's apps at this stage, it will help us understand where the trip points are and try and adjust documentation as a result.

  • 0

    I finally got it working.  Thanks, Jake!  The tip about the browser console was helpful.  Looking there led me to installed.js, where I discovered a syntax error in my app.js file.

  • 0

    I have same problem as above.

    I checked the console.

    An 500 error occurs when loading installed.js.

    I tried to install the example app changing the app name, author, and image files, but I still get the error.

    Could you tell me why the error occurs?

  • 0

    Hey Yuko, 

    In your manifest.json you specify a defaultLocale of "ja" but you have no actual translation file in your app, so Zendesk is bombing as it can't find that file. To remedy, please take a look at http://developer.zendesk.com/documentation/apps/i18n.html

    That said, we should the system should have brought this to your attention sooner, as I'm sure it's an easy mistake to make. We'll add something into the upload process that will stop the build if it finds this problem and tell you how to fix it.

  • 0

    Hi Jake,

    Thank you for checking my apps.
    I found I have made an another mistake that I did not add the Archive.zip file.
    When I added the files to apps, it worked fine.
    I did not think the file is required.

    In addition to the translation files, I think it would be better if the system tells you when Archive.zip is missing on the upload process.

Please sign in to leave a comment.