Customizing Help Center "Swiftest Elk"

Answered

11 Comments

  • Wes Drury
    Comment actions Permalink

    @Amanda - It looks like you need to edit the below class from your CSS tab.  If you look at line 463 you can edit the following.

    .category h2 {
    background: #FFF !important;
    }

     

    This will change the boxes to white so just adjust however you would like. Use the !important so that this class will not get overridden with any other class.   In the future if you right click on those boxes and select "Inspect Element" then it will show you the class that you need to edit.  Just let me know if you run into any other issues.

    0
  • Amanda Winston1
    Comment actions Permalink

    @Wes Thanks for this solution.  You're right that's where to change it (although I was hoping to find one place to change these group headings as well as the "Ask a Question" box and the right frame/sidebar boxes.

    I must say I thought you were wrong till I tried it,  since the theme's default entry,

    .category h2 {
      background: $color_3;

    states that it's going to use color_3, and our color_3 is hex #404040 whereas the color appearing in the boxes is not #404040 (and updating color 3 in the Appearances section causes no change to these boxes) , it's very strange and explains why I couldn't find the entry in the code.

    Is there somewhere in the CSS that I can redefine the value for color_3?  If not, can you assist me in locating the lines that would allow me to update the color for the "Ask a Question" box and right-hand boxes that also appear in that medium-grey shade?

    Many thanks!

    0
  • Wes Drury
    Comment actions Permalink

    @Amanda - I will take a look as soon as I can.

    0
  • Wes Drury
    Comment actions Permalink

    @Amanda - Line 317 .hero-unit {  will change the Ask a Question box.  Just change the background color to which ever you would like.  Just like we did above.

    Line 425 .community {

    I'm seeing two backgrounds used on all the classes so one of the backgrounds colors are overriding the others.  If you want to use the color_3 then I believe you will need to add the !important so it will know which one to use.  If not you can simply do what we did in the first post.

    Just let me know if you need help with anything else.

    0
  • Wes Drury
    Comment actions Permalink

    Ok I think I'm understanding what you are doing so yes you need to do the following so the correct background color is chosen if you go this route:

    background: $color_3 !important;

     

    0
  • Amanda Winston1
    Comment actions Permalink

    Thank you Wes, I finally got a chance to take another stab at it and this has really helped. 

    ---- For those that may stumble upon the thread ----

    While adding important to line already specifying to use color_3 didn't work: background: $color_3 !important;

    Specifying the exact color did: background: #FFF !important;


    I think the last pieces I'm having trouble is where to specify the color of the stars that indicate "promoted articles" as well the Magnifying glass icon that shows in the search bar (ours is disappearing right now because it's white, as is the bkgrd).

    Maybe I'm pushing my luck, but any chance you can help me find those as well?

    0
  • Wes Drury
    Comment actions Permalink

    @Amanda - For promoted articles star: (add last line)

    .article-promoted span, .visibility-internal {
      cursor: default;
      position: relative;  
    color: #0080ff ; 
    }
    
    
    
    

     

    For magnifying glass: (add last line)

    .search-box:before, .sub-nav .search:before {
      content: "\1F50D";
      font-family: "entypo";
      font-size: 1.25em;
      line-height: 0;
      position: absolute;
      text-align: center;
      top: 50%;
      width: 2.5em;
      z-index: 1;  
    color: #0080ff; 
    }
    
    
    
    
    0
  • Cameron Berne
    Comment actions Permalink

    Was this theme removed?? I had it selected for my helpcenter and it somehow switched to Copenhagen and appears to no longer be an option?? How did this happen and why?

    0
  • Wes Drury
    Comment actions Permalink

    @Cameron - Default themes do not get removed however you can view other themes while your main theme is active.  If you did any custom changes then your theme will be located after all the default themes and will have a default name of Custom Theme.  Select "Switch Theme" option to see and change back to your current theme.

    0
  • Joel Hellman
    Comment actions Permalink

    Actually a recent update happened here, where if you were using an 'legacy' theme like Swiftest Elk, and switched to the Copenhagen theme and did the Publish action, you might be prevented to switching back to your old theme.

    Read more here: Help Center legacy theme updates

    Edit: if you created a custom theme (=made modifications to a theme and published it) however, I believe you would be able to switch back to that theme. 

    0
  • Wes Drury
    Comment actions Permalink

    Thanks Joel - I missed that announcement.  I just checked and my custom themes are still there.

    0

Post is closed for comments.

Powered by Zendesk