My users are not getting the responses submitted by us

6 Comments

  • Diane Albert

    Hi Shalabh

    Having those macros / triggers / automations layered can make troubleshooting tough!

    On the ticket on the last comment, there should be a Show All Events button - that will let you see what things fired when the correspondence was sent.  I start there when I troubleshoot.

    Just to clarify, you were solving your ticket - is this correct?  You're done with it, no more comments are expected?

    Is your Notify Requester of Update different than Notify Requester of Solved?  We've had conditions on certain triggers that have actually cancelled out the triggers that were supposed to run. Tags are one of the main reasons in my world for this to happen.

    Please feel free to post a capture of your trigger and of just the events (with any personal information blurred) of your ticket.  We can do a spot check here to see if something pops out.

    diane

    0
  • TeamTakeSurveys

    Hi Dianne,

    Unfortunately, I don't see a 'Show All Events' button in the ticket. :(

    Yes, I am solving the tickets, no more comments expected.

    I don't see a 'Notify Requester of Solved' trigger in my account. Below is the screenshot of all the active triggers in my account:

    Is this the issue? Should I create this trigger as well? I never created/deleted any trigger though so not sure why it's not there.

    Thanks!

    Shalabh

    0
  • TeamTakeSurveys

    So, I was able to figure out the 'Show Event' button. Below is what I see for the test email I sent today:

    Note: I never received anything about the received request.

    I guess it says that the trigger was successful but I didn't get any response on my email address. :(

    Please let me know what we can do to resolve this. It's very critical as there many pending tickets that we need to resolve.

    Thanks!

    Shalabh

    0
  • Diane Albert

    @Shalabh...it certainly won't hurt to open a direct support ticket if you're on the Team Plan or above so that someone can look at your account more closely.

    Here's where I'd be looking for additional troubleshooting on your own. 

    • has ANY outbound email from zendesk worked ever?
    • Open the trigger that says it's firing, but isn't getting an email to the customer.  There isn't an image of that here.  Is there something in the trigger itself that sets a condition which is preventing the email from being sent further down the line?  For instance, do you know for sure that nothing else has been set up to block "incident" type tickets - because that what you've shown here.  I have a trigger that IS supposed to suppress emails with certain conditions.  A previous admin updated it to exclude one type of support ticket and caused a chain reaction that was pretty nasty.

    Can any other fellow Moderators weigh in on this one?

    Hopefully we can get you some additional suggestions soon. 

    Diane

     

     

    0
  • TeamTakeSurveys

    @Diane, Thank for the help.

    Outbound emails were definitely working earlier on our account.

    I checked the triggers but I don't see any condition that should prevent users to get update from us. Below is the screenshot of one of the trigger:

     

     

    I did open a support ticket but still waiting on a resolution from the team.

    Thanks!

    Shalabh

    0
  • Jessie Schutz
    Zendesk Team Member

    Hey Shalabh!

    Can you try changing your Ticket: Comment is... condition to Present, and requester can see the comment

    Edit: In the process of writing this response I forgot that you had shown that the trigger was actually firing, but the notification wasn't getting through to the end user. Oops!

    Make sure that the requester on your test tickets are end-users, not agents. I usually use a personal email address to do testing like this in my test instance. You'll also want to make sure that the end-user is the one being added as the requester...sometimes this doesn't happen if you're bringing tickets in through a webform.

    Keep us posted on how things are going!

    0

Post is closed for comments.

Powered by Zendesk