Back up your Help Center articles at the click of a button!

168 Comments

  • Jennifer Rowe
    Comment actions Permalink

    Hey Felix,

    Congrats on getting the app certified! It's a great addition to our marketplace. 

    Looking forward to seeing where you take it from here!

    0
  • Felix Stubner
    Comment actions Permalink

    Hey Jennifer,

    Thanks so much! Really appreciate all the support you guys have given me to help get to this point.

    0
  • Jessie Schutz
    Comment actions Permalink

    Felix, you're a beast! We're so glad you're part of our Community! <3

    0
  • Jenny Berger
    Comment actions Permalink

    Hi Felix -- thanks for your work on this & getting it out to the community!

    Just having the following issue:

    When I enter my Zendesk account details & click Backup, the program window says "Not Responding" for several seconds and then displays the following error:

    "The general exception was hit: Invalid URI: The format of the URI could not be determined."

    When I click OK, another message appears, saying the backup completed & shows the path to the folder.

    When I navigate to the backup folder, there's a single HTML file, an images directory, and the BackupLog.txt file. The images directory is empty, and the single HTML file happens to be the first article in my helpcenter.

    Question: Could this exception be caused by the security option I have set up in my account? (My acct is configured with the SSO option.) 

    Thanks for your help!

    0
  • Felix Stubner
    Comment actions Permalink

    @Jessie - Thanks! Happy to be here :D

    @Jenny - Sorry to hear you run into an issue there, I'd be happy to look into that for you. It's a possibility but as long as you are using the same username and password as you would with SSO then there shouldn't be an issue. It sounds more like there is an issue with the domain entered into the Domain text field.

    Could you possible send me an email to felix.stubner@gmail.com with a link to your help center and I can check into this issue for you. Looking forward to hearing from you.

    0
  • Felix Stubner
    Comment actions Permalink

    The latest release is now available v0.5 fixing a few issues and adding Web Portal support. Come check it out, you can download the latest version here and the links in the article have also been updated. Thank you for checking out this app, I appreciate your support!

    0
  • Sam
    Comment actions Permalink

    The latest version v0.5, has been a great help to me. Thank you Felix!

    0
  • Felix Stubner
    Comment actions Permalink

    @Sam - Thanks so much for giving it a try, I'm glad to hear that it helped you out! :)

    0
  • Abdul Qabiz
    Comment actions Permalink

    @Felix - Awesome! This has been on list for long but I have been super lazy. Thanks for great work, a lot of people are already using it.

    I would love to port it to Mac OSX, can we collaborate on that? 

    Thank you

    -abdul

    --

    Abdul Qabiz

    Diziana

    0
  • Felix Stubner
    Comment actions Permalink

    @Abdul - Indeed I'm glad to hear that people are finding it useful :)

    A Mac OSX version is something that I am currently working on as I have seen a number of requests and users stating that they use Mac so they would need to find a PC to run it on instead. Which doesn't sounds too great ^.^ Hopefully should have something ready during the next week. Feel free to email me though what your thoughts were. felix.stubner@gmail.com

     

    0
  • Andrew Ritchie
    Comment actions Permalink

    Hi Felix, 

    Glad to see you got this one certified, we were very disappointed when it disappeared for a while!

    Currently running across a couple of problems with 0.5

    1) Images folder is empty (probably a result of problem 2)

    2) When selecting a folder to backup to, the backup file is getting saved in the parent directory, with the folder name appended to the file name. ie. If I select C:\Zendesk\ as the backup path. The file will be saved at C:\ and called ZendeskBackup_20160822-090125

    3) If you have already completed a backup, then click Backup, but Cancel from the folder selection screen, the backup still occurs (to the previously selected folder path) :)

    I'm surprised others haven't reported this, so maybe they are unique to me!

    Cheers,

    andrew

    0
  • Felix Stubner
    Comment actions Permalink

    @Andrew - Thanks for checking out the app, appreciate the support! Sorry to hear you are running into some issues. Could you email me at felix.stubner@gmail.com and I can have a look into it for you. Thanks again, speak to you soon.

    0
  • Joseph Collins
    Comment actions Permalink

    Hi Felix, this tool is great, and makes backing everything up much easier -- thanks!

    Do you have plans to add support for multiple languages? It looks like it only backs up the source language for each article.

    0
  • Felix Stubner
    Comment actions Permalink

    @Joseph - Thanks so much for your interest in kBackup, glad to hear it's making life easier for you! :)

    Indeed, this is something I would like to add. Getting language specific articles is not too different from getting just the source articles, I just need to think about how best to implement it ^.^ 

    @everyone who has requested or suggested features, I want you to know that I have read every piece of feedback and have taken it on board and am looking to continue improving kBackup :)

    0
  • Jason
    Comment actions Permalink

    I just wanted to leave a quick note, saying that the app has been working great on our end. We have made it a part of our official support procedures. Thanks for pulling this together.

    Cheers

    0
  • Felix Stubner
    Comment actions Permalink

    @Jason - That's great to hear! You are very welcome Jason, I'm pleased that it has had such a positive impact on your support procedures.

    0
  • Felix Stubner
    Comment actions Permalink

    Hey guys, sorry about the delay on the Mac release, still hammering out some bugs. Will keep you updated. Thanks for your patience :)

    0
  • Haley Qu
    Comment actions Permalink

    I really like this tool. And have some suggestion:

    1. it will be more convenient if this tool can remember the domain and email 

    2. The image in restrict article cannot be saved.. I can only see the image in public content.

    Thanks for your improving.

    0
  • Felix Stubner
    Comment actions Permalink

    @Hayley - Thanks for taking the time to give some feedback/suggestions, I really appreciate it. At the moment I am working on getting a Mac release out but once this is complete I can go ahead and continue implementing new features. Thanks for trying out kBackup :)

    0
  • Ewan Parker
    Comment actions Permalink

    hey felix, how would I go about restoring this back up?

     

    Love the app.

    0
  • Felix Stubner
    Comment actions Permalink

    @Ewan - Thanks for checking out the app, glad to hear you like it! :) 

    At this time the app only supports backup, however for the next release I am looking into restore functionality but it will require some effort to make it work. I update this topic every time I create a new release so keep an eye out.

    0
  • Felix Stubner
    Comment actions Permalink

    @Ewan - I wanted to add something to my previous reply as I did not actually mention how one would restore the content once backed up. 

    At the moment there is no automatic restoration through the app. The way the restoration process would currently work is that you would:

    1. Create a new article in Zendesk
    2. Open one of the backed up .html files in Notepad
    3. Copy everything between the <body></body> tags
    4. In the Zendesk article editor select code view, it's the little button with <> on it
    5. Now paste your copied code in there and click Ok
    6. If there were no images then simply copy and paste the text between the <h1></h1> tags into the article title and you are good to go. 
    7. If you have images then you need to look at the article id of the backed up .html file (this is the name of the file itself) and then check the images folder in the backup directory for images that start with the same article id.

    That should allow you to restore the articles. I understand it is not the best way to go about it but I am looking to include some restore functionality in a future release. Hope that helps! :)

    0
  • Felix Stubner
    Comment actions Permalink

    @Lovely Mac users - My sincerest apologies to you guys for the delay of the Mac release. Unfortunately I no longer have access to the Mac that I was using to port the app. I am currently looking into getting a replacement. Thanks again for checking out kBackup, I appreciate your patience.

    0
  • Kim R Robinson
    Comment actions Permalink

    I know you have done a lot of work improving this. I have a question, though, so once the HTML files of each article is backed up, is there an automated way to put them back up in the event all is lost or is it going to be just copy and paste?

    1
  • Felix Stubner
    Comment actions Permalink

    @Kim - thanks for checking out the app! :) Indeed, at the moment it only backs up the articles and they need to be restored manually via copy and paste, simply by copying the html into the html editor when restoring an article. I do have plans to enhance this functional in the future to also allow for restoring but it's still a work in progress. Thanks again for dropping by :)

    0
  • Corrin Duque
    Comment actions Permalink

    @Felix

    Thank you for the valuable tool!  We had over 400 articles that represented countless hours of work and backup via JSON export was just not going to fit our requirements.  

    Looks like the tool runs like streamlined efficient magic!

    We have several iorad tutorials and videos which of course will not pull through in the export.  But the screen prints all seem to have made it through in tact with no visible changes to article layout or format.  Very cool tool.  Thanks!

    0
  • Felix Stubner
    Comment actions Permalink

    @Corrin - Thanks for trying out kBackup and glad to hear that it has been so useful to you.

    I have been thinking about looking into supporting the backup of videos too, but that really depends on where the videos are hosted. If you could give me an idea of where you host your videos I may start adding support bit by bit.

    Thanks again and have a lovely weekend! :)

    0
  • Corrin Duque
    Comment actions Permalink

    Thanks Felix,

    We host our videos via Wistia. Prior to purchasing Zendesk we provided users with direct Playlist access.  Here's a sample.  In Zendesk we embed both individual stand alone videos and playlists.

    https://etailsolutions.wistia.com/projects/e4s7l0hvk7

    sample of an embedded playlist:

    0
  • Corrin Duque
    Comment actions Permalink

    @ Felix

    Thanks for including the instructions for restoring articles (via copy paste of the code).  

    A couple questions:

    Any ideas how this might work for bulk import?  You mentioned you might be looking to do something along these lines.  Something in the works or just straight manual article by article for the foreseeable future?

    Currently we have over 450 articles.  Only 25 are videos and 40 are iorad tutorials with the remaining being articles with screen prints.  The total size of the entire download was 805 KB.  The image folder has only one screen print in it.  In preview mode of Windows File Explorer the images do not appear.  I went through and opened various HTML pages to see the images did indeed show up in tact once the HTML doc was opened.  How are these files being stored/exported?  Does this size seem odd to you for 450 articles with images?

    0
  • Felix Stubner
    Comment actions Permalink

    @Corrin - Thanks for getting back to me with the info on how you host your videos. 

    Indeed, I am working on a version that allows for the restoration of content in bulk. This is a little more complicated than simply backing up the articles but I am hoping to have a working prototype towards the first week of November. 

    Regarding the images, I will need to test this out for myself, could you email me your Zendesk sub-domain to felix.stubner@gmail.com and I'll be able to investigate this and let you know if the behavior you are seeing is correct or not. 

    There are always new ways that I come across how users store images so my current code may not account for the way the images are being stored. If the image in the article is a direct link to a .jpeg or .png or a direct link to any image file type it should download these, however I have seen that in some instances the images aren't stored with a direct link. Therefore trying a backup of your data myself will allow me to check it out.

    Looking forward to hearing from you.

    0

Please sign in to leave a comment.

Powered by Zendesk