Enabling and configuring Answer Bot for the Web Widget

Pinned

33 Comments

  • Andrew

    Is there a site where we can see a working example?  My main concern is around making it too difficult to contact support, especially if there's another required question after viewing an article and clicking "no I need help".  Also, how it handles random input from customers like "Hello?" or "I need help"

    From agent perspective, it seems like creating tickets for every search could actually make more tickets.  Will we see which articles were suggested and viewed to better answer the customer's question?

    One disappointment is losing contextual search - we use it extensively and some pages are able to be targeted really well (e.g. when a customer is viewing a report, suggest "Reports overview" article)  I think there is still an opportunity to incorporate that into this widget.

    0
  • Mike Mortimer

    Hi Andrew, thanks for your comment!

    You can view a demo by heading to answerbot.zendesk.com and interacting with the widget there. The HC has been preloaded with some of the Answer Bot FAQs so you can ask a question about Answer Bot to Answer Bot and it'll Answer Bot you some suggested articles (so meta!)

    In terms of how it handles the situation of "Hello?" etc, the contact escalation channels are offered after a short delay, so customers who need to get connected to a real person will always have that option, likewise if Answer Bot doesn't find a matching article or the articles returned can't help - channel escalation options will always be available.

    We don't create tickets for every search, rather only those that were marked as solved (and thus won't clutter the agent experience) - it means you get all the benefits of being able to tag, apply ticket fields, etc, after the fact if you needed to / wanted to, as well as full reporting capabilities that tie back to article performance. You can isolate all Answer Bot reporting from this channel using the "Channel" dimension and selecting "Answer Bot for Web Widget" in Insights.

    Agreed, bringing the context through to the agent is a huge value prop that's been part of Answer Bot in other channels for a long time - right now we auto-populate the question asked into the message to help prevent the user needing to type that message again, but we absolutely have plans to provide much deeper integrated contextual data for both the chat and ticket escalation cases in the future as we continue to build on the EAP.

    We definitely want to bring contextual help back into the Answer Bot Widget experience as we continue to build out from the initial EAP experience.

    I'd love to get you onto the EAP however it looks like you don't have an active Answer Bot subscription or trial

    0
  • Richard Moyles

    Hi All, 

    I managed to get Answer Bot working on the widget in our help centre by copying & pasting the code as suggested, however, the main widget on our websites does not offer Answer Bot.

     

    Update 09/05/18

    The issue for us was a hard-coded contextual help setting.

    0
  • Jonas

    Hi,

    I managed to get Answer Bot for the Web Widget working, but under "Insights / Answer Bot / Ticket Via", I can't find Answer Bot for Web Widget. Where exactly do I have to look for it? 

    0
  • Adam Gudmundsson

    Hi,

    Same issue as Richard. Although didn't yet attempt to add it to helpcenter.
    Is it because of the "Web Widget Integrated Chat Experience EAP"? 

    0
  • Jaime Bonacif

    Hi,

    I followed the steps in the post, but the Answer Bot does not return the articles after adding a keyword word or phrase in the message field.

    By disabling the Answer Bot and searching for the same keyword in the search field, I get the most influential articles on the subject.

    Can you help me please?

    0
  • Adam Gudmundsson

    The previous issue resolved.

     

    @Jamie, what language are you searching for? 
    I'm not sure how connected the regular search widget and the bot are. Since the regular search accepts any language while the bot only accepts a few. 

    Not sure why it would be able to speak for example Swedish but not find the results. Perhaps the search algorithm is more complext.

    0
  • Jaime Bonacif

    Adam,

    I'm using the Portuguese language. Currently it is enabled in our emails, and it works normally.

    0
  • Adam Gudmundsson

    yea, that should work according to Zendesk.

    "Answer Bot in the Web Widget supports the same languages as Answer Bot in the web form and email: English, Spanish, Portuguese, German, French, and Dutch"
    https://support.zendesk.com/hc/en-us/articles/360001121068-Announcing-Answer-Bot-for-the-Web-Widget-EAP 

    If you followed these steps and didn't forget to disabled "Contextual Help" then I don't know, sorry.

    1. Click the Admin icon () in the sidebar, then select Channels > Widget.
    2. Click the Customization tab. If you have multiple brands, select the widget for the brand you want to use with Answer Bot, then click Customization.
    3. Make sure the Help Center option is toggled On, to display the Answer Bot toggle.
    4. Click the Answer Bot toggle to On. If you have Contextual Help enabled for the widget, it will be disabled.
    0
  • Jaime Bonacif

    Adam,

    I followed all these steps and "Contextual Help" is disabled automatically when I enable the Answer Bot.

    I'm going to open a ticket for Zendesk. Thank you for your help.

    0
  • Maggie

    Hello, 

    We've been using Answer Bot for the Web Widget for about a week now, and have a couple questions/feedback. 

    1. We'd like to create a trigger to tag the solved Answer Bot tickets that come into Zendesk, but don't have anything to trigger off of. The only way to find the Solved Answer Bot tickets in Zendesk is by searching "Unknown (Answer Bot)". Is there a best practice for setting up business rules around these solved requests?
    2. Is there a way for customers to opt-out of the chat bot? For example, if the customer doesn't want to chat with Answer Bot, but would rather just initiate live chat with an agent, is there a way for them to do this without experiencing the chat bot, or do they have to engage with Answer Bot first?
    3. Are there any plans to customize the message being used within Answer Bot?
    4. What kind of improvements are planned for Answer Bot for the Web Widget, if any?

    Thanks!

    0
  • Mariliam

    Hi, I was just testing your Zendesk AB Help Center, and I noticed the AB was not really offering any articles even when my queries were, word for word, questions regarding articles in your help center: https://answerbot.zendesk.com/hc/en-us 

    Wondering if there's something wrong? Was testing this before making it live on our own HC. 

    0
  • Mike Mortimer

    Hey Marilliam, thanks for alerting us to this. We had a brief server routing issue that were causing some article suggestion requests to fail. This was rectified pretty quickly and is all working 100% again now. Let us know if you see any issues. Thanks again!

    https://cl.ly/2e0P2H0K3U3v

    0
  • Allan Talabis

    Under what circumstances would the AnswerBot for Web Widget not be able to find any relevant articles, but the email AnswerBot does?  I am still on a trial and am wondering if this can be the reason?  We are concerned with this inconsistent behaviour between the email and web widget channels for AnswerBot.

    0
  • Jon Daniels

    Hey Stephen!

    This is expected behavior with the widget by default, but I think you will find the instructions in the following article helpful in your case:

    Using restricted Help Center content with the Web Widget

    With the setup outlined above, your users will see those articles within your widget, as long as they are authenticated.

    Hope this helps!

    0
  • Mike Mortimer

    Currently in the Answer Bot for Web Widget EAP it does not support restricted content at all (please disregard the advice from Jon which applies to the standard Widget experience only). This limitation would have been communicated in the welcome email - we are looking to bring in support for restricted content in the future

    1
  • Mike Mortimer

    Oh awesome, yes many ways to get into a "restricted" state at the overall help center and article level. Glad to hear you've adjusted the settings, got it working and are enjoying it! :)

    0
  • Edison Harada

    Hi Mike,

     

    I have a problem with the Answer Bot, I notice that when I activate the Answer Bot somehow it stopped creating the cookies to maintain the session with the user ("__cfduid" and "__zlcmid"), so every time that a user refreshes the page the live chat will be lost.

    I'm using the Answer Bot and Live chat with the web widgets ( with this tag  "<script id="ze-snippet" src="https://static.zdassets.com/ekr/snippet.js?key<KEY>="> </script>").

    I already tested it, and after the bot answers the user and give the option to have the live chat, it should create the cookies but it doesn't create it.


    Could you help me to solve this?

    0
  • Mike Mortimer

    Hi Edison, we've created a bug for this and hope to have it resolved shortly. Thanks for raising it

    0
  • Edison Harada

    Hi Mike, Could keep me updated about this bug?

    Thanks

    0
  • Mike Mortimer

    Hi Edison, the fix is just waiting for deployment - should be resolved by next week.

    0
  • Mike Mortimer

    Hi Edison, the fix has been deployed if you wanted to retry and confirm? Let us know if you're still seeing the problems. Thanks for your patience on this one.

    1
  • Edison Harada

    It's fixed, thanks =)

    0
  • Madhavan Buddha

    @Mike - Please help us with the following issue:

    We are able to capture tickets only when Answerbot answers correctly i.e. only when the end user clicks "Yes, the article was helpful". But, we don't get any tickets if the user clicks "No, the article did not help" or simply doesn't select any response (even if responses may have been correct). So, we don't know how many times Answerbot  answered incorrectly/provided unsatisfactory responses nor how many times end users did not select any feedback response. The dialogue between Answerbot and end user is not available in the database. Could you fix this or suggest where we can get this insight ? Without this insight, it is difficult for us to understand how answerbot is performing.

    Another issue is, we don't know who the end user is . Request you to enable this too.

     cc: Anil.Murthy@pfizer.com

    0
  • Claudia Pelagatti

    Hello Madhavan,

    I will address your questions below:

    1)This is correct and how it's supposed to work. In order to create a ticket the user must click "Leave a message".

    2)The data required to do this should be available in Insights soon, no ETA I am afraid.

    3) If a user is not signed in when they use the widget, then we can't discern the end-user. If they are signed-in, their identity will be available when they click "Leave a message" to create a ticket. Unfortunately if they solve a ticket via widget while signed we don't record the user and still return "Unknown (Answer Bot)".


    Claudia Pelagatti | Senior Technical Support Engineer | Rome, Italy | support@zendesk.com


    -1
  • Madhavan Buddha

    @Claudia -Thanks for the responses.

    It seems like the design is such that the end user has to click "Leave a message" every time we, as chat admins/agents, need to be able to realize their unresolved issues through tickets. However, this may lead to poor end-user experience since we cannot mandate our honorable end-users to compulsorily leave a message if their issue is not resolved. Many a time, end users don't like to proceed further if the answerbot does not answer their query properly and they just abandon the bot and move on. I recommend this be taken up as an area of improvement and get fixed in one of your future releases. Ideally, we need access to all the transcripts (successful and unsuccessful conversations between answerbot and end user need to be available for us to diagnose further).

    Regarding my third query on end user ID, your design expects end user to leave a message in order for the end user name to be captured. This may not always happen due to the same reasons I have listed above. Thus, I recommend a fix be made available for identifying end user names even if they have not clicked "Leave a message".

    Regards,

    Madhavan

    cc: Anil.Murthy@pfizer.com

    0
  • cseguier

    Hi,

     

    I have a question about the widget and the automatic text.

    My knowledge base is in 2 languages : French and English. As you can see on the example, when I switch from French to English, the automatic text is always in French.

     

     

    The response to the suggestion is in the wright language.

    How can I adapt the text to the language ?

     

    Christel

     

    0
  • Tim Patullock

    Hey @Christel @cseguier

    Tim here, an engineer with the Embeddables team. 

    I've created a support ticket to investigate this, we should be getting onto this soon. We will post an update when this is resolved.

    Cheers,

    Tim

    0
  • Adam Gudmundsson

    We have somewhat the same issue. 
    It seems answerbot disregards language when searching for articles, and (atleast for us) works better/only works when you write out whole sentences including a question mark. 

    Return package - no result
    How do I return my package? - Gives the correct results
    English is less effected by this, other languages more so. This only happens in answerbot for widget, other search functions gives the correct results with fewer search strings. 

     

    0

Please sign in to leave a comment.

Powered by Zendesk