Your use of document.write jquery is giving us and all your clients a lower score in Google Lighthouse

5 Comments

  • Jeremy Pinson
    Comment actions Permalink

    No response on this one? We are seeing the same error message in Lighthouse and are being penalised also.

    0
  • Daniel Aron
    Comment actions Permalink

    Hi Rene and Jeremy,

    You should only see this error if using the legacy Chat widget. If you switch to the integrated chat Web Widget experience this doesn’t use document.write anymore.

    Hope that helps.

    0
  • Daniel Aron
    Comment actions Permalink

    @Jeremy, a quick follow-up. We looked at the code on your site and whilst you’re using the integrated Web Widget it appears you have an old version of the Web Widget snippet in your code. The legacy snippet used to use document.write to inject the widget onto the page. The new snippet no longer does this and can be found in your Web Widget admin settings under the “Setup” tab. If you replace the old snippet with the new snippet it should help to resolve the issue.

    0
  • Jeremy Pinson
    Comment actions Permalink

    Thanks, Daniel - I appreciate the prompt response! We have updated with the revised snippet to resolve this.

    0
  • Dom Stapleton
    Comment actions Permalink

    Hi Daniel Aron. What if we're using the WooCommerce plugin? This still seems to be using document.write.

    0

Please sign in to leave a comment.

Powered by Zendesk