Embedding a SharePoint Site into an Article

8 Comments

  • Jessie Schutz
    Zendesk team member

    Hi Rich!

    Are you trying to embed the entire site or just certain elements, such as a video?

    0
  • Rich Herbert

    The entire site if possible. I can embed videos ok, but I can't get the site to populate. I can't even get a generic site like google to show up in the frame.

    0
  • Jessie Schutz
    Zendesk team member

    Hey Rich!

    I checked with one of my colleagues on this, and you'll want to make sure that you have enabled the Display unsafe content feature in your Help Center.

    1. In Guide, click the Settings icon in the sidebar.
    2. Under Security, select the Display Unsafe Content option.
    3. Click Update.

    That may do the trick. However, based on the error message it might be that your Sharepoint site doesn't allow iframing/embedding. You'll also want to double check and make sure that your code is correct.

    0
  • Rich Herbert

    Thanks so much for following up. I do have Display Unsafe content selected. I'm thinking perhaps you're correct about the SharePoint permissions, and I've been successful with some commercial sites.  Thanks again! 

    0
  • Jessie Schutz
    Zendesk team member

    No problem, Rich! Let us know if you need anything else!

    0
  • Anthony Inman

    Rich Herbert Jessie Schutz 

    Hi Rich,

    I'm curious to know if you found a solution to this problem you were having embedding Sharepoint into Zendesk? I am having a similar problem. I embedded an Excel spreadsheet into an article and it works great, but now some of our people working offsite are getting the my.sharepoint.com refused to connect. I would love to know what you found out.

    Regards,

    Tony I

    0
  • Rich Herbert

    Hi Tony, 

    Unfortunately we were never able to solve this due to our internal SharePoint security settings. 

    Thanks!

    Rich

    0
  • Anthony Inman

    Hi Rich Herbert,

    Thanks for your quick reply. Since the lockdown, we have folks working from home on Chromebooks that are getting this message. I'm scouring the internet to find a solution. I will let you know when I find something.

    Best,

    Tony 

    0

Please sign in to leave a comment.

Powered by Zendesk