Users start chat with no information

4 Comments

  • Devan - Community Manager
    Zendesk Community Team

    Hello Kevin,

    So if a number is coming up vs. the customer's email address, this is likely due to your setting not being toggled correctly to require this information. I would check to make sure this isn't the case since the number you are seeing is indeed the result of an email not being input. I've gone ahead and linked below an article that goes into detail on how to set this up on your end.

    Enabling pre-chat form

    0
  • Andrew Lo

    I am having the same issue with our end users showing up as numbers.

    You can see it here:

     

    All users on our site are assigned a First Name and last name and that is what usually shows up. 

    We have the Pre-chat form OFF since we have a very specific set of users that we already have their first and last names. 

    Right now, we aren't able to know who the user is since it is showing as a number. Typically we know exactly who is sending the chat request. 

    0
  • Brett - Community Manager
    Zendesk Community Team

    Hi Andrew,

    To have the user's information displayed in Chat correctly you would need to enable the Pre-Chat form or use the ze.identify function to auto-populate your logged-in users. More information can be found in our web widget resources here: Web Widget resources

    I hope this points you in the right direction!

    0
  • jackmin

    We have the same issue now? we integrate the chat sdk in our app. Before starting the chat we add user info in the chat configution, why we miss the user info? only show the Visitor 49390366. It's from ios app.

    0

Please sign in to leave a comment.

Powered by Zendesk