Console warnings in Chrome browser: A cookie associated with a cross-site resource at <URL> was set without the `SameSite` attribute.

38 Comments

  • Rob Marks

    Jumping in as this is now causing issues for our end-users as well. 

    0
  • Maxime LUTZ

    Hello,

    I'm still having this warning :

    A cookie associated with a cross-site resource at https://assets.zendesk.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. 

     

    Is there some news from zendesk ?

     

    Thank you

    0
  • Brett Bowser
    Zendesk Community Team

    Hey Maxime,

    I did some digging on my end but it doesn't look like we have any updates to provide at this time. This issue still occurs even after clearing your browsers cache/cookies? If so, I'm happy to bring this into a ticket so our Advocacy team can dig into this further with you.

    I also encourage you to take a look at the following article as it provides some additional information on cookie restricted browsers: Zendesk support for cookie-restricted browsers (Safari, Chrome)

    I hope this helps!

    0
  • Maxime LUTZ

    Hello Brett,

    After cleaning my browser cache/cookie I have no more alerts.

    Thank you,

     

     

    0
  • Brett Bowser
    Zendesk Community Team

    Glad to hear it Maxime!

    0
  • Camille Acey

    I have been able to reproduce this issue on Firefox and I am not sure what is the workaround. 

    Camille 

    0
  • Devan - Community Manager
    Zendesk Community Team

    Hello Camille,

    So after checking with our dev team, we don't currently have any updates to announce on this. I would recommend for now sharing your use case in the following article as it is the one we are actively monitoring regarding this issue. 

    Zendesk Support for cookie-restricted browsers (Safari, Chrome)

    Best regards. 

    0
  • Devan - Community Manager
    Zendesk Community Team

    Hello Ryan,

    A workaround that you can do to resolve this issue is by setting the Chrome://flags/#same-site-by-default-cookies flag to disabled for the meantime.

    We currently need to disable SameSite default by cookies, because Chrome rolled out an update that blocks cookies without cross-site requests if they are not set with ‘SameSite=None’ and ‘Secure.’ However, last April 3, they recently did a rollback of this update for Chrome 80 in light of global circumstances due to COVID-19. For more details about it, you may check this article: Chrome's SameSite Updates

    I hope this helps! Let me know if you have further questions or clarifications.

    Best regards,

    -1

Please sign in to leave a comment.

Powered by Zendesk