Guide - JS/CSS assets are returning 403 errors

2 Comments

  • Agnes Abel

    We found that the Zendesk server (or CDN) is blocking requests from this user agent (google bot).

    We have been able to reproduce the http request that fails:

    The url of the asset (any asset that fails) is the same, the only thing is that the user-agent should be: Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5X Build/MMB29P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.96 Mobile Safari/537.36 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

    Seems like +http://www.google.com/bot.html at the end is the reason of the issue.

    When this is sent, instead of receiving the asset we receive this message:

    An action you just performed triggered a security alert and blocked your access to this page. This could be because you submitted a SQL command, a certain word or phrase, or invalid data. 
    If this continues to happen, create a HTTP archive file (follow this tutorial) with the issue reproduced and send the file to us.
    RayID: 52b29363ef3e6113 
    IP: 62.97.88.134

    Has anyone experienced the same and has it been possible to adjust on Zendesk's end?

    0
  • Devan - Community Manager
    Zendesk Community Team

    Hello Agnes,

    Looks like our team is working with you in this in a ticket currently that is awaiting a reply from you. If there is anything else though that the Community can help you with please don't hesitate to ask and have a wonderful day.

    Best regards.

    0

Please sign in to leave a comment.

Powered by Zendesk