Editing content block changes puts all articles into "In progress" review status

10 Comments

  • Nelli Laine

    I'm seeing this same thing happening in my articles. I'm using bulk publishing to publish these articles when I know that there hasn't been any other changes except the Content block.

    However, in some cases the article won't change to published even though it is published several times. I can't figure out how to get this fixed. The changes seem to be saved and published but the article status is still In progress. Confusing.

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    Thank you so much for your feedback. At the moment Content Blocks are closely coupled with articles so the system treats a change to a content block as a change to an article and because of that, it puts it in an "in progress state". It's also a safer option for introducing CB functionality as we could foresee a scenario where a draft article containing a content block is accidentally published after an update to the content block.

    But it became apparent from feedback like yours that we should think about splitting workflows of CB and articles so that they can be edited, managed, and published separately from each other. We'll be introducing a series of improvements in this area next year. 

    Nelli Laine not seeing the article published sounds like a bug. Can you tell me more about it?

    0
  • Ashleigh Dietz

    Hi Katarzyna,

    We experienced a similar issue as Nelli yesterday. An agent had content blocks enabled on an article and when an agent with publishing rights went to publish, the article said it was published but also was still stuck in Review Status. 

    We disabled content blocks and were able to publish. We aren't currently using content blocks at wide scale but wanted to see if you have any insight into what is going on here. 

    Thanks!

    Ashleigh

    0
  • Nelli Laine

    Hi, Exactly like Ashleigh Dietz described. The changes are saved and we were able to confirm that but the article remains in "In progress" status. As soon as the CB was removed from the article I was able to save it as Published. I'm happy to help you with troubleshooting, just let me know what you need from me.

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    I see it now, thank you for sharing. We have a known issue at the moment with some events (like saving) not coming to the system in the right order witch may cause articles to be stuck in a certain state. One of my team is solely focusing on a holistic solution to this problem and I expect improvement soon. 

    0
  • Nelli Laine

    Hi, are there any news about this bug? We had to stop using the CB because this caused a lot of confusion and uncertainty. Thank you if you can provide an update to this!

    0
  • Patrick Morgan

    Katarzyna Karpinska just echoing Nelli Laine. Any update on this? I'm seeing this happen, too.

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    Hi Patrick Morgan, the issue with different states being processed by the system in the wrong order (e.g. published articles being thrown back to review state) should have been resolved recently. Can you share what's your current experience?

    0
  • Patrick Morgan

    Katarzyna Karpinska hmm... I did notice issue when I first enabled Content Blocks a couple weeks ago, but what I am experiencing now may be a larger issue with publication statuses in general. I have just found around 50 articles (most without Content Blocks) inexplicably moved to "In Progress" with no changes made. I'll submit a separate ticket with this issue.

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    Patrick Morgan, that would help us a lot with investigating it, can you please tag me in it? Thank you!

    0

Please sign in to leave a comment.

Powered by Zendesk