Content blocks can´t be disabled on article

6 Comments

  • Katarzyna Karpinska
    Zendesk Product Manager

    Hi @...,

    We are slowly moving into the reusable content world where Content Blocks will be permanently present. Therefore once they are enabled on the article they are there to stay. The article's functionality with or without the content blocks is the same and you don't have to use content blocks in a given article if you don't have a need for it. 

    0
  • Tobias Hermanns

    Hi,

    thanks for this info, which bring us into a problem.

    a) The link still show Disable button and need modify:https://support.zendesk.com/hc/en-us/articles/360039549873

    b) We click enable on some article by incident and the article ID is changed from 36XXX Format to a new format. This format is not able to query from API and some of our Apps for translation of article are unable to work now so we need to convert this article back.

     

    Is there any chance to do it or we need re-create these article?

     

    When API will be supported to grab new ID article?

     

    Thanks.

    /Tobias

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    As we are getting close to GA of CB we are working as well on how they fit our API model. As you rightly pointed out the articles with CBs enabled have a different id format than the rest. It is however still possible to check what is the "old" id format in the Help Center url and use it in your API query.

    We can also help with downgrading this article and I can create a ticket for this.

    Thanks for pointing out outdated documentation, I'll make sure to fix it.

    0
  • Tobias Hermanns

    Hi,

    so far this was not working in my test.

    I found out that the new ID is: 01F14V9QYW8N36J8QEMWV48JB0 where old ID (when open article with publish link is: 360020582320

    I expected this is old format and should work with our API query similar the old before, but so far it failed:

    "{"error":"RecordNotFound","description":"Not found"}"

    So I can´t confirm that your explanation can work.

    We already have Support case open to downgrade these article.

    Kind Regards,

    Tobias

     

    0
  • Katarzyna Karpinska
    Zendesk Product Manager

    Good to hear that you already have a ticket and we'll be able to help you. 

    I might not have made myself clear, the API atm doesn't see the articles with CBs. This will be solved in the next month or so when we move to GA. Then the work-around that I've just described should be working.

    0
  • Tobias Hermanns

    Hi,

     

    this is fine for us, then we know how to continue work and what´s expected.

    I just thought, we may need query "some other API" and enhance our custom APP, but if this is not the case, we wait for update from you guys.

    Thanks for fast clarification.

    Kind Regards,

    Tobias

    0

Please sign in to leave a comment.

Powered by Zendesk