Knowledge Capture App: Heading links do not work

8 Comments

  • Tiffany Rizzo

    I'm having a similar issue! When trying to link headings further down in my article using the hyperlink button, some headings are recognized while others are not, and I can't figure out why. Having a Table of Contents at the top of the article is very helpful and not being able to create one since Zendesk is not recognizing headings is not ideal. I've made sure each heading is in the "Heading 1,2,3,4" etc text format and it still doesn't work. Not sure if this is a bug but I've never had this issue before. Any advice is appreciated!

    2
  • Paige Palmer

    Tiffany Rizzo, I'm having the same issue as you. I noticed it yesterday, but this morning it seems to be worse. I hope it's a known bug and is resolved soon!

    1
  • Holden Hewett

    I am reporting the same issue. This needs to get fixed soon, it's extremely frustrating and adds a bunch of extra work when creating articles.

    I found a workaround that I posted in the official Inserting and editing links in articles article.

     

    Edit: the problem is coming from the fact that headings are no longer automatically generating an id. So once you manually add an id to each heading in your document you can use the headings tab in the links modal without issue. 

    ---

    This comment has been edited by the Zendesk Community Team to remove a link, to comply with our Community Code of Conduct.

    0
  • Tetiana Gron
    Zendesk Product Manager

    Thanks everyone for the feedback! We have addressed the issue with headings in Knowledge in the context panel.

    You can navigate through the article using headings, and you can also send a link to a certain section of the article by linking the heading. Read more Searching linking and quoting content in tickets. You need to have Agent Workspace enabled to use Knowledge.  

    1
  • Paige Palmer

    Tetiana Gron Is there a plan to work on this soon? We noticed that it's happening again but it's very sporadic. This is causing confusion for agents who need to jump down to specific sections. :( 

    0
  • Tetiana Gron
    Zendesk Product Manager

    Hi Paige Palmer,

    This functionality is already implemented. If you still experience issues, please create a ticket with Zendesk and we will look at your particular case. 

     

    0
  • Rayne Puertos

    We are also having this issue. I cant seem to find how to submit a support request.

    0
  • Dave Dyson
    Zendesk Community Manager
    Hi Rayne, here's how to contact our support team: Contacting Zendesk Customer Support
    0

Please sign in to leave a comment.

Powered by Zendesk