Restricting Satisfaction Surveys by Date


  • Brett Bowser
    Zendesk Community Manager

    Hey Morvan,

    If you're using Google Sign-in then you'll still want to set up a native Zendesk password you can use for this target. To set up a native Zendesk login, navigate to and enter your email address to trigger a password reset email.

    You'll replace subdomain with the actual subdomain of your Support account.

    I hope this helps!

  • Karen D Snyder

    @... and @..., I had the same problem last week where I was creating an HTTP target, and got back status HTTP 401 Unauthorized with { "error": "Couldn't authenticate you" }. I solved it (with help from Zendesk support) as follows: In the target settings where you put in your email address, add the string "/token". Where you put in your password, paste in your token.

    We use SSO to sign into Zendesk, so not sure if this solution would apply to everybody.

  • Dominic CX


    My message is a longshot as this thread might not receive attention after 2-3 years, but it's work a shot:

    My target failure is 401, it says "error": "Couldn't authenticate you"

    I have checked in the API and it says  HTTP client call failed.

    Any ideas what the problem could be?




  • Brett Bowser
    Zendesk Community Manager

    Hey Dominic,

    I'm going to create a ticket on your behalf so our Customer Care team can look into this error with you.

    You'll receive an email shortly stating your ticket has been created.


  • Esther Malka

    I'm not seeing the "Requester: Last Satisfaction Date" field in the automations dropdown. Was this removed??

  • Elaine
    Zendesk Customer Care

    Hi Diana,

    The Requester: Last Satisfaction Date field is not natively listed as one of the Conditions or Actions in creating an Automation. As stated above, you will have to create a new/custom date field by following the full instructions above in order for this date to show up in the dropdown option for Conditions or Actions.

    Hope this clears it out. Cheers! :)

  • Paul D Owner

    please update the to:

        "user_fields": {
          "last_csat_date" : "{{ "now" | date: "%s" | plus: 7776000 | date: "%b %d, %Y" }}"


    where 7776000  = 86400 s in a day * x no of days (90 in this case)


Please sign in to leave a comment.

Powered by Zendesk