SUMMARY
Between October 04, 2022 from 20:50 UTC to October 05, 14:46 UTC, customers using Zendesk Support apps leveraging the Ticket Field object in the Apps Support APIs were presented with incorrect field values.
Timeline
14:33 UTC | 07:33 PT
We’re currently investigating reports of Zendesk App Framework customers calling zafClient.get(‘ticketFields’) and being returned with incorrect values. This will impact users whose Apps rely on this feature, including custom and publicly available Apps through our Marketplace.
14:49 UTC | 07:49 PT
We have identified the likely cause of Zendesk Marketplace Support Apps to render incorrect ticket field values and are working on reverting the affected deploy. More information in the next 30 minutes.
15:24 UTC | 08:24 PT
We are happy to report that the issue affecting ticket field values in Zendesk Marketplace Support Apps has been resolved. Thank you for your patience during our investigation.
POST-MORTEM
Root Cause Analysis
This incident was caused by a recent code change, causing an issue in the caching mechanism that resulted in stale data being returned for several API payloads.
Resolution
To fix this issue, the code change was rolled back. We continued to monitor until we had positive customer confirmation of issue resolution.
Remediation Items
- Adding an automated test case to cover this specific scenario, of mirroring a public app’s behaviour when interacting with the Ticket Field object. [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.