SUMMARY
On July 25, 2021 from 12:05 UTC to 15:35 UTC, customers on the Zendesk Chat iOS platform were not receiving push notifications.
Timeline
14:10 UTC | 07:10 PT
We are investigating Chat iOS push notifications not being delivered. Investigation is underway.
14:37 UTC | 07:37 PT
We have identified the cause of the Chat iOS push notifications not being delivered, and our team is working on a resolution. Please note, missed/undelivered notifications will not be resent once this issue has been resolved.
15:08 UTC | 08:08 PT
Our team is still working to reestablish chat iOS notifications. We will keep posting updates.
15:45 UTC | 08:45 PT
We have resolved the issue impacting push notifications in Chat on iOS.
POST-MORTEM
Root Cause Analysis
This incident was caused by an expired Zendesk Chat App certificate for iOS.
Resolution
To fix this issue, a new certificate was generated and recovery was observed soon after.
Remediation Items
- Document chat push certificate renewal process [Scheduled]
- Implement a process for monitoring the expiry of the iOS chat app certificate, and generate new certificates on time. [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.