SUMMARY
On August 26, 2021 from 00:42 UTC to 17:00 UTC, Talk customers saw no results other than numbers starting with country prefix +1 (Canada, US & Puerto Rico phone numbers) when trying to purchase a Talk number.
Timeline
11:54 UTC | 04:54 PT
We are aware of a limited number of country numbers showing as not available for purchase for Zendesk Talk. As a workaround please enter a value into the “Narrow your search” field to see available numbers for other countries.
14:30 UTC | 07:30 PT
Our teams are still hard at work on the issue affecting phone number purchasing for Zendesk Talk. If you are experiencing this and need assistance with the workaround, please reach out to our Customer Advocacy team for assistance. Thank you for your ongoing patience!
17:20 UTC | 10:20 PT
The issue impacting Zendesk Talk phone number purchasing is now resolved. Thank you for your patience as we worked to resolve the issue.
POST-MORTEM
Root Cause Analysis
This incident was caused by an unexpected interaction caused by a change made by our partner carrier.
Resolution
To fix this issue, our partner carrier rolled back the update.
Remediation Items
- Improve monitoring and tracking for country-specific number availability
- Follow up with Twilio to improve rollout process for this update.
- Add additional testing and alerting for number availability during rollout process.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.