SUMMARY
On February 15, 2023 from 04:54 UTC to 16:11 UTC, customers on all Pods experienced an issue that their Salesforce integration was no longer correctly communicating with Zendesk to fetch ticket information.
Timeline
14:30 UTC | 06:30 PT
We’re currently investigating issues with the Zendesk for Salesforce App where customers are seeing “An error has occurred when trying to load tickets. Please check your configurations.” when trying to access their Ticket View functionality. Please bear with us.
15:02 UTC | 07:02 PT
This issue is affecting the Zendesk Ticket View functionality integration within the Salesforce platform, however, tickets can still be viewed in Zendesk Support. We appreciate your patience while we continue checking this further. Next update in 1h or when we have more to share.
16:01 UTC | 08:01 PT
We appreciate your patience while we work through this issue. We have identified a likely cause and are working to get it fixed as soon as possible. Next update in 2h or when we have more details.
08:07 UTC | 00:07 PT
Feb 15 - 18:39 UTC | 10:39 PST We are happy to report that we have resolved the issue affecting the Zendesk Ticket View functionality integration within the Salesforce platform. Thank you for your patience during our investigation.
POST-MORTEM
Root Cause Analysis
The incident was caused by a recent deployment from Zendesk to Salesforce’s third party integration service.
Resolution
To fix this issue, the deployment was rolled back
Remediation Items
- Organise deployment schedule
- Enable alerts for smoke tests for the impacted service
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.