Links to Help Centre from Word/Excel

15 Commentaires

  • Duke Oliver
    Actions pour les commentaires Permalien

    Is it possible for you to share an example word or excel doc? I'm interested in the issue because my team is about to do something similar. If you're uncomfortable with posting an attachment here, I'd love to take a look via email, dkisch@exagoinc.com

    0
  • OT
    Actions pour les commentaires Permalien

    It just happens when you copy and paste a link into a Word doc (like I've done here) but the bigger annoyance for us is that we have an API report on our Community posts which includes links.

    I've done a bit more experimenting and found that if you're logged out then you end up at the right page after logging in.  Also a link to the main Community page works, but anything in the Topics or Posts doesn't (presumably it's checking I'm logged in?).

    Edit - amusingly, if I use the link above, because it opens the document in Word Online and not Word all the links in the document work!

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Do you have the permissions on those docs restricted at all? I'm wondering if that might have something to do with it...

    0
  • OT
    Actions pour les commentaires Permalien

    Hi Jessie

    We seem to get the same behaviour wherever a file is stored.  I did notice though that with the file I linked to before, which is shared from my OneDrive, if I open it in Word on my PC the links take me to the homepage, but if I open it in Word Online then the links go to the correct community pages.

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Hey Ola,

    I just want to make sure that I understand what you're doing here.

    You're putting a link to a Community topic into a Word doc. If you click the link from the Word doc, it takes you to the Help Center home page. But if you copy/page it into the browser it goes to the correct topic.

    Is that right?

    0
  • OT
    Actions pour les commentaires Permalien

    Hi Jessie

    Yes, that's right.  As well as that, if I'm logged out of Zendesk when I click the link then once I log in it goes to the correct topic.

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Okay, as you mentioned in your original comment login is still required for the Community portion of your Help Center. If you're linking to a Community Topic or Post and you're not logged in when you click it, it'll take you to the main page so you can log in first. Unless I'm misunderstanding what's happening, it sounds like everything is working the way it's supposed to.

    Let me know if there's something I'm missing!

    0
  • OT
    Actions pour les commentaires Permalien

    If I'm not logged in, it does take me to the main page to log in, but then re-directs me to the correct page on log in.  The issue is that if I'm already logged in the link takes me to the main page instead of the correct community page.

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Does it want you to log in again? Or does it show that you're logged in and just doesn't take you to the right spot?

    0
  • OT
    Actions pour les commentaires Permalien

    It shows that I'm logged in and just doesn't take me to the right page.

    0
  • Tal Admon
    Actions pour les commentaires Permalien

    Hi Jessie,

    I had a similar issue (Zendesk ticket 884641).

    If this is related I hope to find a solution for my ticket as well.

    Thanks!

    0
  • OT
    Actions pour les commentaires Permalien

    Tal, let me know if you hear anything back as I've never had an answer on this.

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Hey guys!

    Ola, I'm sorry this fell off my radar.

    I checked out Tal's ticket, which is from back in late 2014. Word doesn't actually have access to your browser's session cookies, which is why it's taking you to the login page even though you're already logged in. Word doesn't have any way of knowing that you're logged in.

    Evan, the Support Advocate who helped Tal, checked with our Product Team and was able to find out that at the time the the changes that need to be made on our end to remedy this are substantial enough that they decided not to address it at that point.

    That was a while ago, though, so I will follow up and see if there has been any change on this. Bear with me - it might take some time for me to get the information we need. :)

    0
  • OT
    Actions pour les commentaires Permalien

    Not realising that I had already asked here and been unsuccessful in getting an answer, one of my colleagues raised a support ticket and was given a fix, so we're all sorted now.

    0
  • Jessie Schutz
    Actions pour les commentaires Permalien

    Hey Ola! I'm really glad to hear you were able to get a fix! If you have the time and inclination, it would be great if you could share it here in the Community. I'm sure there are others who have the same question. :)

    0

Vous devez vous connecter pour laisser un commentaire.

Réalisé par Zendesk