I am just starting to test out the application to see how I would use this in practice. I'm seeing a few things that results in the need to name things in specific ways to make the app look closer to a completed product.
- Relationship names display as the actual name of the relationship and don't have a friendly name. In most examples the recommendation is to be descriptive using something like object_to_object as a naming convention. This doesn't look great in a filter even though it is descriptive. It would be nice to be able to show a friendly name like "Devices" if the relationship is user_to_devices.
- Property names seem to need a "display_name" or "name" property in order to properly be used in the application, otherwise the record displays as the full object ID. It may make sense to have the docs updated to reflect that this is a requirement.
- A "image_url" seems to be needed to display an image in the object. It would be nice if this was optional, or if blank values in the app could be hidden. URLs can be pretty long and take up a lot of vertical space in the application.
With this being exposed in the UI, it seems like there are some requirements to custom objects that have to be applied that have to be considered to also have the objects look good with the way the app is structured. It would be nice it the app could scale elegantly to account for missing data or for adjustments to names that make sense on the backend, but are not as clean looking on the agent side.
Vous devez vous connecter pour laisser un commentaire.