How can you set the "from" address for outbound emails?

回答済み

26 コメント

  • Jenny Feith
    コメントアクション Permalink

    Hi Jamie,

    Unfortunately it is not possible to set up different outbound email addresses. It will always use your default reply address. This only works for inbound addresses. So if your customer emails you at sales@ - the reply will also be sent from the same sales@ address. Maybe the hub & spoke model which is available on the Enterprise plan, could be an alternative: https://support.zendesk.com/entries/20292353-Setting-up-to-manage-multiple-brand-Zendesk-accounts-Enterprise-

    Although having different outbound email addresses is not exactly the use case of this model - you might be able to use them using a workaround or one of our Service Apps.

    Best,

    1
  • Jenny Feith
    コメントアクション Permalink

    Or even check out one of our Email Marketing integrations like Mailchimp - if you have to send a lot of outbound emails: https://www.zendesk.com/apps/mailchimp-campaign/

    0
  • Jamie Johnstone
    コメントアクション Permalink

    Hey Jenny,

    Thanks for your reply.

    Unfortunately, the enterprise plans are a little outside our price range just to add that one feature, and the Mailchimp option looks like it's for bulk mailing as opposed to sending the odd message.

    We are looking to use this for situations such as while on a phone call we say we'll send out a form to the customer (or something like that - where the contact is initiated via another channel) and create a new ticket inside Zendesk to send this email.

    Can this be added to the feature request list? The specific feature would be the ability to set the 'from' address from one of those already set up in Zendesk (the inbound reply addresses) inside a Trigger. This would let you set up a a trigger that looks at the group or tags assigned to a new email you've just created, set the outbound address correctly, and then sent the email to the requestor.

    Cheers,

    Jamie

    1
  • Emily Page
    コメントアクション Permalink

    Hi Jamie, 

    This is an interesting idea, and one you could certainly post as a feature request to our Product Feedback forum! Our Product Team reviews this forum regularly and it has inspired many of the enhancements we've made to Zendesk over the years.

    0
  • Samuel Vandamme
    コメントアクション Permalink

    Hi,

    I'm having the same issue, is there a solution for this?

     

    0
  • Graeme Carmichael
    コメントアクション Permalink

    Samuael

    There is an App, 'Select an Address' that allows you to choose the address ticket updates are sent from.

    This is in 'Zendesk Labs' (Admin>Apps>Marketplace) so it is not officially supported by Zendesk.

    1
  • Costel Olteanu
    コメントアクション Permalink

    Hi, it worked for me. Thanks!!

    0
  • Colin Piper
    コメントアクション Permalink

    I posted a tip a long while back on how to do this with a url target. ://support.zendesk.com/hc/en-us/community/posts/203464558-Setting-the-default-reply-email-address-using-a-trigger

    However using a http target is far better and I know I have posted that somewhere on these forums but I cannot find it currently. The http target is so powerful and you can update anything almost using it. In this case you are updating a field called recipient.

    1
  • Colin Piper
    コメントアクション Permalink

    I found some of my notes on using the http target:

    HTTP target

    Title: Update Zendesk Ticket

    Url: https://domain.zendesk.com/api/v2/tickets/{{ticket.id}}.json

    Method: PUT

    Content Type: JSON

    Basic Authentication: Enabled (use an agents login with "/token" on the end and then use the API key as the password)

     

    Trigger

    Set any conditions you need

    Perform these actions:

    Notifications: Notify target      Update Zendesk Ticket

    JSON body:

    {"ticket": {"recipient": "accounts@support.domain.com", "custom_fields" : [{"id":29710328, "value": true}]}}

     

    Some notes:

    1) In this example I not only set the Recipient value but also the value of another custom field. Just to illustrate the power

    2) The email address MUST be one that is verified as a Zendesk support email address. if not then your default support address will be used. 

    3) This update does not happen immediately. Therefore if you need to update the Recipient before you send an email notification (perhaps when a  ticket is created) you will need to do a little more trickery first. 

    4) Updating the Recipient does NOT cause an update event on the ticket therefore you cannot then fire more triggers based upon this change. 

    1
  • Avil Mascarenhas
    コメントアクション Permalink

    HI @Colin

    For the 3rd point which you mentioned -

    This update does not happen immediately. Therefore if you need to update the Recipient before you send an email notification (perhaps when a  ticket is created) you will need to do a little more trickery first. 

    Whether the trick is to not to send the auto response via trigger, but to add a sleep tag and use this in automation to delay the initial email?

    But this will delay the auto response and may also affect our SLA's.

    Or is there any other trick that you used :)

    0
  • Brett - Community Manager
    コメントアクション Permalink

    Hi Avil,

    The automation would most likely be the way to go here so there would be a delay in your auto-response to the requester of the ticket. Which SLA target you are you concerned about here if you were to use the automation?

     

    0
  • Avil Mascarenhas
    コメントアクション Permalink

    Since Automation runs only once in an hour, the auto response for few cases can come after 1 hour and till then we might have to wait for the response from our customer, and we miss out 1 hour of not able to act on it

    0
  • Brett - Community Manager
    コメントアクション Permalink

    Hey Avil,

    The auto-responses sent out from automations would not count towards your SLA targets either way unfortunately. If you're looking at the First Reply Time then this target can only be met once an agent posts a public response to the ticket manually via email or through the agent interface.

    0
  • McCabe Tonna
    コメントアクション Permalink

    I was able to use Colin's suggestion and with some tweaks got it working perfectly.

    This was so we can use triggers/automations to bulk notify people from a no-reply email address.

    We use our no-reply email for specific escalations. 

    1) Channels > Email .. Create a no-reply@yourdomain 

    2) Settings > Extensions > HTTP Target

         a) https://yourdomain.zendesk.com/api/v2/tickets/{{ticket.id}}.json

         b) Method: Put, JSON data, Basic auth.. your username/token API token

    3) this part must be 2 triggers

        a) First part is you need to update your ticket to utilize the proper recipient (the "from" part of the email)

        b)

    c) This trigger waits for the previous trigger to finish

     

    Hope this helps

    2
  • Brett - Community Manager
    コメントアクション Permalink

    Awesome work McCabe!

    Thanks for sharing this solution :)

    0
  • Ryan H
    コメントアクション Permalink

    McCabe Tonna thanks for the amazing suggestion. I have it working and firing but my request received notification still seems to be going out with the wrong e-mail address. However, any subsequent e-mails that are sent after are using the correct reply-to address. I'm having issues achieving that delay that you seem to have successfully achieved. Would appreciate some feedback on where i'm going wrong. Hopefully this helps some others as well. Please see the screenshots from my sandbox attached:

    1) Trigger to set the reply-to e-mail once the ticket is created (Set DK Group Default E-mail)

     

     

    2) Ticket received notification (Notify requester of received request - DK):

    0
  • McCabe Tonna
    コメントアクション Permalink

    Okay so the email should not go out on the Ticket is received Trigger.

    Notify the target after your ticket is updated using the first trigger

     

    Does that make sense? 

     

    0
  • Ryan H
    コメントアクション Permalink

    McCabe Tonna / McCabe Tonna Can you clarify? Are you saying I should break up my second trigger again? 

    I tried to follow your example and created two triggers as shown in my post. The first one sets the reply to and tags when the ticket is created. The second one checks for the tag when the ticket is created and sends the received notification.


    Sorry a little unclear on exactly what you mean. 

    0
  • McCabe Tonna
    コメントアクション Permalink

    Hi Ryan,

    Oh try this - try swapping the order of your triggers around. 

    (i had a long hypothesis written up, but this might be a quicker solution) 

     

    My order is set the No-reply with the target

    then below is the actual email the requester

     

    0
  • Ryan H
    コメントアクション Permalink

    McCabe Tonna / McCabe Tonna sorry again i'm not following. I believe that's what I already had done? The trigger screen shots are in order that I posted. The first one sets the reply to address when the ticket is created or updated. The one after that sends the ticket received notification. That's the same order I have in my sandbox environment as well. Am I missing something in my triggers?

    0
  • McCabe Tonna
    コメントアクション Permalink

    @ryan Can you screenshot the triggers that are firing when a ticket is made?

    Ticket Created (1st trigger)

     

     

    This trigger at bottom  (this is the "your request was received) (note this trigger does not have any "your ticket was created or updated conditions") 

    And since it sits below the setting the no-reply target it gets hit just after the address is set

     

    this is ticket received looks like:

    Sorry for all the blur - have to keep PII safe 

    0
  • Ryan H
    コメントアクション Permalink

    McCabe Tonna / McCabe Tonna 

    Thanks for getting back to me and further clarifying. Still seems to be doing the same thing even after the changes I made to mirror yours more closely. Edited my other post with the screenshots to show what the update looks like. 

    0
  • Dan Cooper
    コメントアクション Permalink

    Hi Ryan, 

    McCabe asked for a second set of eyes to see if maybe something else might be going on here.  I'm not anything jumping out that would make me thing you are following his instructions incorrectly, but I'm thinking through my experiences here and there are some other things that might be going on. 

    The first trigger is making an API call that could take a moment to process.  If your Zendesk instance doesn't have many triggers, it's possible that your Zendesk is hitting the second trigger before the API call actually finishes.  While the tag is applied - the API call may not have finished to actually update the recipient address.  Try separating the two trigger positions so they are farther apart to see if that might give you a little time while other triggers process on the ticket. 

    Also, check to see if the API call is actually succeeding. It's possible that the call is not properly authenticating and failing to make the update.  This may happen due to incorrect credentials or you may be running into issues where you are hitting API rate limits.  You can check your API dashboard and see if your Targets are listing any errors.  When you run these sorts of triggers, you don't get much in error handling - so it's likely this is failing due to something like this. 

    Another thing might be that the email address may not be configured appropriately.  If you have a hosted email address that has not been properly setup for mail forwarding, it would default to you default address on your Zendesk.  Take a look at your Support address settings to ensure that the secondary address is functioning properly.  If you are already using that address in other contexts (for example with the Select an Address app) this wouldn't be the problem. 

    0
  • Dan Cooper
    コメントアクション Permalink

    Hey Ryan,

    I missed that you stated that subsequent replies are using the correct address - so the last two suggestions aren't going to be your problem.  Try separating the two triggers a bit.  If you can't, consider trying to set the second trigger up as an automation instead and put it on a delay of an hour since created/updated (just make sure you nullify that condition so it doesn't continue firing) if you can afford that kind of a delay on the emails.  

    Best of luck! 

    0
  • Ryan H
    コメントアクション Permalink

    McCabe Tonna & Dan Cooper

     

    Thank you both for looking into this. I've tried to move the second trigger to the last position in the trigger list but that doesn't seem to have fixed it. I will admit there aren't that many triggers in my sandbox. There's maybe 20. So maybe it wasn't enough of a delay i'm not sure.


    I've thought about using the automation as well but I believe those loop and fire once an hour roughly? I would be ok with maybe a 10-15min delay but an hour seems to be quite a lot. By that time the Agent may have already replied to or solved the ticket.

    In my instance customers have a learned behaviour to expect the ticket received e-mail when they submit a form or e-mail, etc. I'm not sure what the best path forward on this would be. Was really hoping to get this to work as it's nearly there just missing the first hit. Everything after that works beautifully as expected. Really appreciate all the help and the example as well. 

    0
  • Dan Cooper
    コメントアクション Permalink

    There are some posts in the Product Feedback section that cover recipient address that you can add feedback on (I even think I’ve written a few - I’d link if I wasn’t on mobile) it’s worth voicing feedback over there to try to get some traction here. It’s a common challenge for teams with multiple email addresses.

    0

ログインしてコメントを残してください。

Powered by Zendesk