Providing links in Zendesk theme that default to users' current language

回答済み

5 コメント

  • Louise Dissing
    コメントアクション Permalink

    Hi Jason,

    I'm unsure of this custom theme that you are using, but talking about links, in general, I can tell you that you can indeed make a link that is not forcing a language.

    This link is forcing language: /hc/en-us/categories/123456789_my_category
    This link is not forcing language: /hc/categories/123456789_my_category

    I hope this helps you. :-)

    #helpsome regards,
    Louise Dissing
    Team Lead @ helphouse.io

    0
  • Jason K
    コメントアクション Permalink

    Louise Dissing

    Thank you for the response. I did try removing the "en-us" in the url and it unfortunately didn't work. The result was a 404 error when clicking on the linked element. I am going to take a look at it today with someone who knows more than I and if we can find an answer I will be sure to circle back with the resolution.

    0
  • Louise Dissing
    コメントアクション Permalink

    Hi Jason,

     

    Perhaps you created an absolute link instead of a relative one.
    In your link only write what I send, and not your Zendesk domain in front of it.

    It did the trick on our Guide at least! :-)

    If you still cannot figure out why, could you then copy-paste some part of the code into here?

    #helpsome regards,
    Louise Dissing
    Team Lead @ helphouse.io 

    0
  • Jason K
    コメントアクション Permalink

    You are (absolutely) correct. I ended up with categories/123456789_my_category and all is working as expected. I wasn't aware that I could provide a link in that way so I also learned something. 

    Thank you Louise!

    0
  • Louise Dissing
    コメントアクション Permalink

    Hi Jason,

    Great! Glad I could help! :-)

    #helpsome regards,
    Louise Dissing
    Team Lead @ helphouse.io 

    0

ログインしてコメントを残してください。

Powered by Zendesk