Chat trigger fires after chat has ended

11 댓글

  • Brett - Community Manager
    댓글 작업 고유 링크

    Hi Jenni,

    This definitely seems like odd behavior since the trigger has fired after the Chat session has ended and the visitor has been served. I'm wondering if it's because you have Still on site as the 3rd condition and there's a delay before the next condition is checked. In this case, there's a 210 second delay before the trigger checks to see if the visitor has been served or not.

    If you relocate the Visitor served condition to the top of the trigger does that resolve the issue for you? I would think that as long as you have this condition first you wouldn't need the Visitor triggered condition at all.

    Let me know!

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    Hi Brett, 

    This unfortunately did not help, what it did was that the trigger was fired after the customer had already received a reply from an agent. Any thoughts? 

    0
  • Brett - Community Manager
    댓글 작업 고유 링크

    Hi Jenni,

    Any chance you could provide me with a screenshot of the newly configured trigger so I can take a look for you?

    Thanks in advance!

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    Hi Brett, 
    I changed it to this and now it doesn't fire at all: 

    0
  • Brett - Community Manager
    댓글 작업 고유 링크

    Hey Jenni,

    It looks like you're using Visitor served > is true. Can you switch this to Visitor served > is false to see if the trigger fires correctly?

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    Yup, I noticed that right after posting :D 
    I changed it and it looks like it's working now, I'll get back if it still fires after the chat but so far so good :)
    Thanks for all your help!

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    Oh man, it fired after I've replied to a client :( I can't have it on until I know it works for sure. The only thing I changed was the Visitor served > is true to Visitor served > is false. 

    0
  • Brett - Community Manager
    댓글 작업 고유 링크

    Hey Jenni,

    I may need to bring this into a ticket for you. Before I do, can you confirm you have Fire only once per visitor enabled for this trigger? Screenshot for you below:

    I'm wondering if this trigger keeps checking for those conditions even after you reply. In this case we only want it to fire once.

    Let me know!

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    I think it works now! I tested it and it only fired when I hadn't been helped, the chat had not started: 

     

    0
  • Jenni Hedman-liback
    댓글 작업 고유 링크

    Hi, this still seems to fire even after I've closed down a chat! 

     

    0
  • Brett - Community Manager
    댓글 작업 고유 링크

    Hi Jenni,

    I'm going to bring this into a ticket so our Customer Advocacy team can troubleshoot further.

    You'll receive an email shortly stating your ticket has been created. Feel free to reply back to that email with any additional information you can provide.

    Thanks!

    0

댓글을 남기려면 로그인하세요.

Zendesk 제공