Dashboard and Data Filters across tabs

답변함

9 댓글

  • Marie-Cathrine Sørensen
    Community Moderator

    Hi Aidan,

    I have noticed that in order for changes to affect multiple tabs at once, the filters have to be 100% identical. This applies to both time and data filters. The best way to ensure this is to create the filter in one tab and then copy and paste it into the other tabs using the standard keyboard shortcuts (cmd/ctrl + c and cmd/ctrl + v).

    I hope this helps.

    #helpsome regards,
    Marie-Cathrine Sørensen
    Business Intelligence Analyst @ helphouse.io

    0
  • Aidan Ryan

    Thanks Marie-Cathrine. 

    I'm sure they are the same but will check once again. I notice that I don't have this issue with Time/Date filters. they do work seamlessly across tabs but other filters do not.

    0
  • Marie-Cathrine Sørensen
    Community Moderator

    Just have in mind that they should both be based on the same dataset (eg. Tickets) and then linked to the other (eg. SLA), if it makes sense :) Otherwise, don't hesitate to get back and I will try to help you. 

    #helpsome regards,
    Marie-Cathrine Sørensen
    Business Intelligence Analyst @ helphouse.io

    0
  • Aidan Ryan

    Thanks Marie-Catherine, Yes, they are on different datasets but are linked. If the same queries are on same tab, all is working but as soon as I move to another tab, I have to re-enter the attribute query (Ticket Organisation Name) on the other tab .

    0
  • Marie-Cathrine Sørensen
    Community Moderator

    My suggestion would be to try and follow these steps:

    1. Delete the old data filters.
    2. Create a new filter in one of the tabs using the Ticket dataset.
    3. Select your attribute.
    4. Link it to the attribute in the SLA dataset.
    5. Copy and paste the filter into the other tab. 

    This works for me and filters all tabs that the filter has been copied onto at once. 

    1
  • Aidan Ryan

    Marie-Catherine, you are a genius !!!!

    Copying and pasting seems to have them finally working. Thank you so much !

    1
  • Harold

    Has this changed over the last 10 months?

    After a whole afternoon of fiddling it now seems to work following Marie-Cathrines recipe. Thank you!

    I want to add: it seems important that you copy the first filter you make to all the other tabs. So don't copy 1 to 2, 2 to 3 and 3 to 4, but 1 to 2, 1 to 3 and 1 to 4.  

    It's so annoying that the simplest things are so obfuscated, convoluted and hard to do in Explore :( 

    (edited multiple times, final result above)

    1
  • Punit Dadlani

    You indeed have to copy and paste across tabs for this to work, and it all has to come from 1 tab as you (Harold) suggest.  Not a great experience at all. 

    The issue I have with this is that when you copy and paste, the alignment gets completely screwed up on the new tabs, so you need to literally do all of that work all over again...would be nice if someone thought about the upkeep required here.

    0
  • Cameron Ball

    Agreed with Punit Dadlani, this is quite frustrating. Just want to second this here. Maybe Zendesk can bump this to their product team soon.

    I have it working for my setup, but it has very unpredictable behavior. I'll go to one tab, click the filter, and the current tab filters like it should. I switch to another tab, and the filter didn't copy across. I go back to the original tab, and the filter is now gone (??). I switch to the 2nd tab again, select the filter from there, and it works on that tab. I go back to the original tab, and now it did copy across, proving that I have my setup working correctly, but it is just a buggy feature. Very strange.

    This powerful feature seems to be an afterthought from Zendesk's perspective. Many seemingly obvious things and workflows require strange hacky workarounds in Zendesk.

     

    Edit: After some research, I now understand why it was being "buggy" before, although the problem still exists. Say you refresh the page or open a dashboard for the first time. You have to click through all tabs and wait for them to initialize and for their data to load. Only then can you select a filter on one page and it will transfer across all tabs. If you select a filter on one tab, then navigate to another tab before loading it first, it will erase the filter from the original tab and not transfer anything. Now while this itself is something that should be fixed, it would be even better for Zendesk to just build this feature into their product from the get-go so people don't have to manually set this up for 9 different tabs. Rant over, haha.

     

    1

댓글을 남기려면 로그인하세요.

Zendesk 제공