Why didn't this trigger work?

Respondida

3 Comentários

  • Graeme Carmichael
    Ações de comentário Permalink

    Elizabeth

    I am not sure if this is how things are intended to work, but the trigger will not fire in this instance because of your first condition:

    • Ticket Agent Replies equals 0

    This is what I would expect. First the agent makes a public reply. Then submits the ticket. Then the trigger fires. So, by the time the trigger fires, the agent replies count equals 1. The condition fails, the trigger does not fire.

    Now, the spooky thing is, that applies when the customer has made the first comment.

    Where the agent makes the first comment on a new ticket, your trigger will fire. I do not follow that as I would have thought the same logic would apply.

    But in your case, you would need to remove the agent comment count condition for the trigger to apply on this ticket.

    Hope that helps.

    0
  • Elizabeth Toy
    Ações de comentário Permalink

    Thanks Graeme! I'd forgotten I posted this and was surprised when a Google search brought me back to my own post. 😅

     

    But you're correct, setting it at agent replies is zero is why it wasn't working. I set it so agent replies are greater than 0 and agent replies are less than 2. Worked perfectly!

    0
  • Nicole - Community Manager
    Ações de comentário Permalink

    This thread has been closed for comments by the Zendesk Community Team. If you have a question you'd like to ask the Zendesk Community, please create a new post

    0

Publicação fechada para comentários.

Powered by Zendesk